no audio devices in new version audacity [SOLVED]

justb uploaded new version and no audio devices can be found checked previous comments and tried tools re configure with no difference

Ensure that you have set the Windows “microphone permissions” to allow Audacity access (Windows calls all audio input devices “microphone” in this context).

internal port audio error message

audacity not showing up in permissions window

Where? When? What exactly does it say?

I have the same problem.
When I’m lunching audacity there is an error window that says “internal portAudio error”
My mic is activated and verified in windows. But audacity cant see that.
Then it enters the program and when I hit record button appears error message “Error: 0 success”.
And in the properties in recording devices properties there is nothing literally, just white box
Plz help me!!!

Is there no error code number?

Could I join in also, I have been a week without audacity and have tried all sorts.Windows 10 64bit, Asus G750 laptop.
First message: Could not find any audio devices, I ok this, tried transport rescan devices. Edit/preferences shows the host and device to be blank. If I press record, I get error opening recording device. Error code 0 success.
Please help. Katie.

What audio devices were you hoping to use?

Nothing special - speakers (realtek high def) and microphone(realtek high def)
The speakers work ok for other websites

Do you have any other audio software running (including things like Skype / Zoom)?

Yes skype, itunes, amazon music

and zoom. If you think it will help I am happy to remove skype and zoom.

I know that by default, Skype runs in the background all the time. The others may too - I don’t know.

Try rebooting your computer, then manually shut down Skype and any other audio apps that may be running (can be a bit tricky as Windows tends to hide most of the systray (notification area) icons - this page may be helpful:

When you feel confident that no other audio apps are running, launch Audacity and see if any device options show up in the Device Toolbar.

I have removed the zoom app and 3 skype apps but have been left with skype for business which is difficult to remove but have ticked the box to say do not open on startup. Still no joy, what else can I try?

Do you have Voicemeeter or any other “virtual audio device” installed?

Hi I relooked at my apps and programs. I removed:
Voice recorder
Max recorder
Music Bee
Nothing helped but finally I could see in my sound list I had DFX speakers but they werent my default speakers. When I tested them in the sound control panel there was no sound. I decided I didnt really need them anyway so removed the ‘DFX’ audio enhancer program which has resolved the problem!
Thankyou for your support. I hope this might help someone else. :smiley:

Super, and thanks for posting the solution.