New User Monitoring Issue

Hi everyone,

I am a brand new Audacity user. I am running Audacity 2.4.2 on a Mac laptop running Mojave 10.14.6. I cannot hear myself in my headsets when I speak. I have clicked “start monitoring” and can see input signal but cannot see (or hear) any live output.

I CAN hear playback audio when I record.

Gone into Mac preferences and made sure that I have selected the correct input/output configurations.

Any advice from you more experienced types out there?

Many thanks in advance.

Audacity > Preferences > Recording > [X] Playthrough.


Thanks Koz! now about the latency fix???

now about the latency fix???

Sure. No Problem.

The Recording Latency you set by putting your headphones next to your microphone and play a click or rhythm track in Overdub. When you play the old and new tracks later, the difference in time is the correction you apply to Audacity > Preferences > Devices > Latency. Test it again to make sure you got it OK. If you hit it, you can play or sing to a backing track and your voice will match the backing track beat perfectly.

No doubt you want to hear your voice in your headphones. That’s perfect overdubbing—your live voice and the backing track overlayed in theatrical mix. To get that you have to listen to your microphone, mixer, or interface. Not the computer.

The computer sound is always going to be “one computer late” and have an echo. Unfortunately, this also means you can’t have wireless headphones, since microphones, interfaces, and mixers don’t support wireless.

We have to tell you that it’s possible to compile the Audacity program with ASIO support and ASIO services can help reduce the echo. Regular Audacity can’t be included with ASIO because Audacity is free and ASIO isn’t.


Sorry. I always forget this step. You can’t have Playthrough on while you’re overdubbing.


In the same place you get told to turn Playthrough off, you turn Overdub on.

Screen Shot 2021-02-16 at 6.04.53 PM.png


Thank you Koz, I truly appreciate your help and I think I get it. Right now just using the computer mic as I await the arrival of other gear. But I will try this.

Lisa :slight_smile: