New installation cannot access a non-existent file

I have been using Audacity (3.0.2, Win 10) on another pc and when I went to install it on my new pc (again, 3.0.2, Win 10) I thought I’d be clever and bring the files accross from the old location to the new.

I restarted Audacity and got the following error:
Audacity error.jpg
There is plenty of disk and I even went to the lengths of adding the Everyone role to C:\Users as Read/Write.

In doing the copy carelessly (I’ve only worked in IT in fairly technical roles since 1986, I’m more careless and idiotic by the day it seems), I think something must have got screwed up (especially for the uninstall process) but now, no matter what I do I can’t start Audacity.

I have renamed the Roaming Audacity folder, I have searched the Registry and found nothing that references Audacity.cfg, I have uninstalled and reinstalled a good few times, sometimes with a reboot between, sometimes removing the Audacity folder, sometimes using Run As Admininistrator, even though the account I’m using is in the Admins group, so now I’m hoping that someone can save me from myself…



I am similarly at a loss… Did you try creating a new user?

Personally I wouldn’t even attempt to “fix” this. I would undo all of the changes, delete all of the files and folders that have been changed, and start again the “proper” way:
Log in as the user, then run the Audacity installer. Check that it works, then log out and move on to the next one.

@jademan - just tried it, and got the same error with a different file:
Audacity error 2.png
Tried uninstalling and installing as Admin and got the original error.

All I can imagine is that there is some right or priviledge that the installer doesn’t have. I cannot imagine what this is as both of these accounts are in the Admin group, and I have not set this machine up to have ultra-paranoid security or anything.

@steve - I have done all of this already I’m afraid, right down to cleanign the registry of references to Audacity, and as above, there is something funky going on withthe installer on this machine, and with the fact that I just tried to install on a clean User, I am now sure that my original actions are not the cause.

Debugging install sequences is out of my normal world, so if anyone has any good suggestions as to how I log the install process for further investigations, now is the time for them.

It’s not as simple as running the installer from a CLI and throwing some switches at it, had a go using the /LOG switch (found through /?) on the executable, but it failed with an error, probably as I’m at the limit of my knowledge.

Did that work, or did it have the same problem?

Perhaps there is some strange Policy on you machine - are you the only one in IT?

Regardless, seeing that you are the only one I can find that has ever reported this problem, the next step may be to reinstall Windows. You might find it to be faster than chasing your tail.

@steve - same problem I’m afraid

@jademan - I’m not in IT for this, the problem is on my personal machine, and no, I keep things as simple as possible at home. tbh, a rebuild feels a little ott for how much I use Audacity, I think I may just just keep my old machine alive for a while until I can sensibly extract the projects I want to keep, I use such a shallow set of features that I’m sure most freebie tools will cover my need nowadays.

Thanks for trying everyone, if I do work it out (and I’m sure I will as I hate being beaten) I’ll update the thread…

As I mentioned, I hate to be beaten, so I got to the bottom of it and now it works.

After some trial and error (and many restore points) it seems that running SFC /SCANNOW found some dll errors that it fixed.

It also found some overlaps of directory ownership, though from the look of them these weren’t to do with this problem.

Long and short of it is if you open a command prompt as Administrator and enter SFC /SCANNOW it fixes plenty of what ails a machine and it worked in this case.

Thanks for the update MultumInParvo. Pleased to hear that you’ve fixed the problems on the computer and that it is now working.

Thanks for the report - I’ll have to put this in my toolkit. :smiley: