Need some help: Blue Yeti Mic not found in program Preferences: Devices

Hello all,

So I have been using Audacity for a few years now and I really enjoy it! I have recently started making YouTube/Rumble videos and decided to get a Blue Yeti Mic to record better sound. The only issue is when I try to record with my mic in Audacity, nothing is recorded (just a straight line).

I have already set up my mic with my computer in the System Preferences and my computer recognizes the mic.

Next, I tried quitting and restarting Audacity. When I started a new project, I am unable to select the Yeti Mic from either the Preferences: Devices section or the top bar of a project window.

Before I quit and restarted Audacity, it seemed to recognize my mic from the Preferences: Devices section but not in the upper bar of the main project screen, which is really weird.

I tried for over an hour and am not sure what to do. I may be missing something. Any and all help is greatly appreciated!

  • MGV

You may have to explicitly instruct the OS to permit Audacity to use the mic, (a privacy thing).

Oh, ok. I recall I enabled a “privacy” somewhere, but I can’t quite recall where it

And I’m sorry, I forgot to mention I’m on a Mac. What is the Mac-version of the change account privacy settings/app permissions protocol mentioned in the quote?

I’m a Windows guy, but Mac Security Settings.

Alright so apparently all I needed to do was shut off my computer, come back from work, and turn it back on; I’m able to select my microphone in the upper bar and now I can record.

I’m not sure if closing and opening back up my computer is what actually fixed it, but this seems to be the one thing that worked for me. Either way, thank you everyone for your help!