Need help with cleaning audio, "chapel" effect

First, let me give my specs:

Windows OS: Windows 10 Home
Audacity: 3.1.2
Microphone: Blue Yeti set to Cardioid mode, about a foot from my mouth, standing upright with pop filter, gain knob set a little past half
Recording area: homemade recording box with moving blankets, noise suppression panels on wall beside me and behind the recording box, heavy quilt on stand behind me
Audio recorded project rate: 44100Hz in mono at recording volume of 0.55
Exported: as mp3 constant bitrate of 192kbps channel mode joint stereo

I record this in my home office and built the recording box after asking some questions here a year or so ago. It does well enough without being professional, but I’m looking to up my quality. When listening through computer speakers, the audio sounds fine enough. When listening through headphones, it has a sort of chapel sound, like it’s echoey a bit? I record audio for side work sometimes, and a few clients recently have said my finished audio (the edited file) sounds muffled or far from the mic. The edited file has the following macro run on it after I have used noise reduction to remove background noise:

Filter Curve EQ: factory preset low rolloff for speech
Loudness Normalization: RMS to -20dB
Limiter: Soft Limit, 0, 0, -3.50, 10.00, no
De-Clicker: found on this forum
De-Esser: found on this forum
Auburn Sounds Couture: settings in photo attachment

For noise reduction, it is set to: 9, 6, 9. I came to this number after looking at the Audacity wiki suggestions.

I use these for all audio I produce (as well as noise reduction to start), unless it’s for an audiobook in which case I do not run the Couture, but do run the others. The first to run is the filter curve, and then they work down in succession.

I understand this might just be an issue with my recording area in that I need a professional box or a better microphone, but I wanted opinions before jumping to spend hundreds. If anymore info needs to be provided, I can do so.

There’s no echo or conspicuous reverb(eration) on your “original.mp3 (216.73 KiB)”,
(just slightly muffled + 120Hz mains hum).

If you can hear chapel-level echo/reverb when you play it, that could be due to Windows adding a playback enhancement, (which is not baked-in to the recording).
Here’s how to switch-off Windows playback enhancements …

The mains-hum can be removed with a notch filter at 120Hz Q=10.
The muffled tone can be corrected by cutting the bass & boosting the treble