Need help solving this problem on Audacity not recording the desktop audio perfectly

To start off, my windows version is windows 10, while my Audacity version is 2.4.2

Now for the problem, it appears that Audacity can’t record my desktop audio perfectly.

This video I made explains it better: (The description also lists the settings I have)

Now that you saw the video, please help me try to solve this issue I have with Audacity. Thanks! Also yes I know you’re getting deja vu because I did make a similar forum post like this, but it’s not that popular so I made a new forum post because of that.

I did make a similar forum post

One reason a posting might slide off the forum is if nobody can figure out what’s wrong or how to fix it. This isn’t a help desk. It’s a forum with users helping each other. If you have a unique problem, there may not be anybody that knows the solution.

Recording music playing on the computer can be done different ways. You have to force the playback system and the record system to run at the same time and then connect them together. The legacy systems used to connect the analog parts of the soundcard together and the sound would have all the distortions of the entire playback channel and entire record channel added together.

If your other recording method uses ASIO software and drivers then you’re stuck. Audacity doesn’t directly support ASIO. Audacity can only use the processes provided by Windows.

There are hardware ways to do this. Some digital sound mixers have the usual overdubbing controls and pathways, but also have the ability to send the playback sound back down the record pathway in addition to what ever the rest of the mixer is doing—all digital the whole way.


In the Windows Sound control panel, ensure that all Windows Enhancements are turned off (See:
Also try enabling “Exclusive mode” (If this stops the recording, change it back to the current settings).

Ok guys, sorry for the long wait, but I tried out disabling window enhancements and when I recorded, the audio was ALMOST PERFECT. There was also exclusive mode but that was already enabled, so I disabled it and it didn’t make things better so I re-enabled it. Also here’s the attachment that goes along with how the audio is almost perfect after disabling audio enhancements.
After disabling audio enhancements.png