Need Help Fixing Clipping


I have recorded over 90 min of material. Unfortunately, I have a fair amount of intermittent momentary clipping throughout.

I’m quite new at recording and I couldn’t figure out what was going on during the session. Levels seem good except at intermittent moments when they would jump significantly without pattern or warning.

I was using an Audio Technica Pro 70 lavalier and a Tascam DR-D60 field recorder to record a woman’s speaking voice.

After viewing the audio and video tracks I think it had to do with the talent’s vocalizing techniques especially her plosives.

Now, I need to figure out how to repair. Can anyone offer any advice? Are there any tools or workflows in Audacity or even elsewhere that might be helpful? I’m not that familiar with the program but I did look it over and, so far, nothing jumped out at me.

Would appreciate any suggestions.


There’s Effects > Clip Fix. What it tries to do is “paper over” the worst of the damage. You can’t actually fix clipping because that’s a portion of the recording where there is no recording. It’s like somebody took a small hand gun and fired it at the blue waves.

The question is can you hear the clip points? Listen on good headphones.

If you mount a lavalier too far down it will catch the actor’s breaths in addition to the voice. That will give you enormous peaks in the wave, but you may not be able to hear them. The microphone is intended to go just inside the acoustic shadow of the chin.

Try this. Drag-select a portion of the show with a lot of damaged peaks and Effect > High Pass Filter: 100Hz, 24dB.

Do they all suddenly go away? Then the breath thing is likely what happened. Many of us use the mixer 100Hz filter on voices to prevent that. That and put the lavalier in the right place. Do a world of good.



Thanks for your reply! I thought I responded the other night but I don’t see it here.

I think you touched on my problem. I definitely placed the lavalier lower on the chest than your picture would indicate. My placement was rather consistent with Audio-Technica instructions but my troubled results support your analysis.

I have applied the high pass settings that you advise. They helped significantly in many place but never totally, always leaving some sort of softer click type noise behind. I have one place, so far, that must have been more severely clipped because I’m have trouble repairing it.

Wonder if you have any suggestions for the remaining post “high-pass” click type sounds or the more powerful clipping area.

I am so grateful for your help. As it turns out, very little of the distortion was due to actual clipping. Most due to air hitting the mic. Though not a perfect fix, the “high pass” has allowed me to salvage most of my footage.


So did you try Clip Fix for the more damaged area?

You can also zoom in to almost where you can see the individual audio samples and try Effect > Repair .

Does the clipping sound like “esses”? If so you could try Lisp . It’s a VST plug-in. Please see here for how to install VST Plug-ins: Audacity Manual .


Hi Gale,

Thanks for your reply!

Yes, I did. It didn’t seem to have much effect. I did get it to round out the top of one of my distorted wave forms but there is still problems with it.

I tried repair but also wasn’t successful. Perhaps, I need to work with it some more.

The clipping doesn’t sound like esses in this particular clip. The problem is with "T"s in this particular clip. I read on the “Lisp” home page that it also works with “teh” sounds. Perhaps, that would help me. I tried to install it but I’m having problems. Please help. Here is what I did:

  1. I downloaded the .zip file.
    I copied the lisp.dll file from the .zip/vst2/x86 folder to the audacity plugins folder.
    I edited Audacity preferences to rescan .vst files upon opening and restarted Audacity.

So, now what?
I expected to see “lisp” in my list of “Effect” drop down list in Audacity but I don’t see it there. Neither to I see anything like “De-Esser”.
Am I looking in the wrong place? Did I do something wrong?
Please help!


Upon further inspection, I did find at least one distorted “s” problem with sibilance which leaves me even more interested in getting “lisp” working.

Looking forward to hearing from you on the install problem.

It may be necessary to scan the whole effect list. External plug-ins have sometimes “VST” or the manufacturers name in front of it.

Here is the install screen that presents when restarting Audacity. Note that Lisp is first on the list.

I simply click “ok” or press enter and Audacity ticks through each item on the list. I interpret this to be installing behaviour but could be wrong. (I’ve since done this multiple times - hope that wasn’t a problem.)

Please help me figure out why this isn’t working for me.

  1. [1] Am I choosing the correct .dll file? VST2/x86/lisp.dll
    [2} Does my install window and process seem correct?
    [3] Why am I presented with the same long list of plugins to install each time? Is this normal or is this an indication that they are not installing?
    [4] If installing each time, is there a problem with multiple installations or does the install just put the same files in the same places?
    [5] Am I looking for the plugin in the right place in Audacity? i.e. The “Effects” drop down list.
    [6] What name does it go by within Audacity? Is it called “Lisp”. (I have a ton of Effects in the drop down. I’ve looked through them many times but I could be missing it if it is called something else.)

Thanks for helping! :confused:

Search under effects for Sleepy-Time DSP: Lisp…

Got it Robert, thanks! Man, sometimes it’s the simple things. I can stop beating my head against the wall. :smiley:

Yes, as Robert said. Audacity cannot use VST 3 and cannot see 64-bit plug-ins on Windows.

Here is another de-esser you can try - but it is best applied to individual defects rather than the whole audio or it will be very slow: . This is a Nyquist plug-in, so there is no need to rescan. Just put it in the Audacity Plug-Ins folder and restart Audacity.


If anyone would like to vote for change, I’ll count votes for always listing VST Effects using the name of the effect (or name of the DLL) or always listing as VST: .

VST: happens if the plug-in reports no name or vendor, but if name and vendor are reported then Audacity lists the vendor name first. So it’s far too easy to see the VST: effects in the list and miss the ones that are listed by vendor.


Again, I’m new at this.

I’ve been trying to fix distortion in some recordings for quite some time now. A little bit of guidance from a more experienced person would probably help. Here is a very brief (one second) sample of a problem section that I’ve been trying to repair:

Might anyone provide me some tips on whether this is fixable and, if so, how to go about it?

Also, can you tell me whether this is an unusual or common type of request? I’m hoping that a few tips will take me a long ways toward resolving this.

thanks in advance!


I’m not an audio engineer, but Pop Mute would turn the bang noise down a bit. The only real solution is not to make the bang noise.

How did you get on with Lisp or De-esser?


The “High Pass Filter” can help a lot with low frequency bumps like that.
Select the affected audio with a bit extra each side so that the selection starts and ends in gaps (close to silence) - that will help to avoid clicks at the start and end of the processed section - then apply the High Pass filter. Try settings around 150 Hz, 24 dB per octave.

I did try High Pass before writing but I did not find it effective unless I set it at 4000 Hz at which frequency it impaired the intended audio more than Pop Mute to my ears.


A fairly steep roll-off is required for it to be effective. The frequency needs to be fairly low so as to not affect the voice too much.