My Blue Yeti making a constant Static noise?

So my first Blue mic was as snowball… that broke within 8 months. Then I got the blue yeti and that broke within a year. So I returned it for a “free” one. Now this one just broke. When I say broke, I mean the audio that it picks up is just static. The first time on my yeti it was just a loud buzzing sound and it didn’t pick up my voice or anything, now it’s a loud static/fuzz but it does pick up my voice… but very faintly. It also continues to make the static sound even when it is muted. Here is an audio clip as an example of when it’s unmuted, then muted(0:06), then unmuted(0:10):
This microphone has been virtually untouched and just stays on my mic stand all day. I didn’t touch it. It just happened out of nowhere. Please, any help would be appreciated!

Neither the Snowball nor the Yeti have any power processing. They try to make audio with the 5 volts that comes down the USB cable (the one that normally runs your keyboard or mouse). If there’s anything wrong with that 5 volts, both microphones have problems.

If you’re just unlucky, you get the Yeti Curse also known as “frying mosquitoes.” That usually happens quietly in the background and screws up people’s AudioBook reading. If you’re super unlucky, the microphones stop working.

You win.

That’s data crossover, by the way, not straight static. You can hear the USB data streams and negotiation where your voice should be.

USB microphones are required to have a home run to the computer, and it should be as short as you can make it. No 25 foot cables across the floor. No hubs with other equipment and no self-powered hubs. Those are deadly.

The USB connection needs to be the shortest one to the motherboard. Generally, that means one in the back of a desktop, not the front or on top. Certainly not a keyboard USB loopthrough.

Try it on another computer. I bet it works just fine, or suddenly works different and better.


The Snowball uses a USB A to B cable. I’m guessing the Yeti does, too. You can temporarily sub the printer cable in case it’s that.


I’ve always had my Yeti plugged directly into the back of my PC, straight from the motherboard. Never had a problem till now. Didn’t touch it. I don’t know what happened but it just started randomly, out of thin air. I’ve tried different USB cables and it doesn’t do anything. I’ve tried an old laptop and it’s the same…

There is a sister posting to this one where someone has a Yeti with a clicking sound. It has so far resisted any effort to solve it.

Microphones do break and USB microphones have the nasty problem of loud and powerful data streams in the same package as tiny, delicate microphone signals.


Check your email.

May be a bit late to the party but for anyone else who may have the same issue you can check out my guide on setting up CST plugins with Voicemeeter to clear up your audio 99% of the time. Took me a few months of searching to find but here it is:

I assume that you mean “VST” plug-ins.

I think that guide will be of limited use for Audacity users as it’s main focus seems to be setting up an ASIO DAW, and Audacity is not an ASIO DAW.

It also requires installing at least 3 other apps, (none of which are open source).

I’ll leave your post here as it may be of interest to some more experienced Audacity users, but due to the differences between ASIO DAW applications and Audacity I expect that most Audacity users would find your suggested workaround to be too complicated.