My Audacity tracks won't record (flat line and mute)

I have a macOS Big Sur 11.4 - I have used audacity many times and it was fine, however the last couple of days I haven’t been able to record anything, when I click to record it is just a flat line and completely mute.
I use an audio interface (the t.mix MicroMix 1 USB) to record via my mic. The last time it “worked” was when I just lay a rough sound down on a track without using external headphones, but then when I connected the external headphones to record it properly this is when the issue occurred. And now since then I can’t record, with or without headphones.
Any help at all would be really helpful as I really need to be able to record soon!

Good morning from Kingston NY

I am in a similar situation in Mojoave. Aside, I am very experienced – about 10 years in Audacity.

I am in a situation with a new install where audio from my interface (I have tried several) will not reach certain apps, including Audacity. It will reach Logic. It will reach iMovie. With Audacity and Zoom I get a flat line. The system is a new setup. I tried reinstalling Audacity to no avail. And I’ve doine every other form of troubleshooting that I can think of.

Ayuto! Grazi.

Ensure that Audacity has permission to access your audio device.
See: Why do I get a flat line and no sound when I record on Mac?

Steve, I’ve never heard of this. The problem arose overnight. No updates upgrades.

Where do I find the permissions that you reference?

See: Why do I get a flat line and no sound when I record on Mac?