Muting in-built mic?

Operating on Mac OS 10.13.3 and Audacity 2.2.1
When copying from USB deck (Audio-Technica) I am unable to mute the built-in mic. When set to “Mute” in “Audio Devices” it reverts to live when I start to record.
I therefore get background noise behind an otherwise good recording.
Is there a simple solution to this problem as this is my first experience with Audacity?

In the Device Toolbar, set Recording Device to “USB Audio CODEC”.
– Bill

Hi Bill, Thanks for your response. In AUDIO MIDI SETUP-AUDIO DEVICES I have selected USB AUDIO CODEC 2 as the input by clicking on the GEAR ICON at the bottom left. The mic symbol moved from BUILT IN INPUT to USB AUDIO CODEC 2, but the microphone is still active.

OK. Now select USB AUDIO CODEC 2 in Audacity’s Device Toolbar.
– Bill

Hi Bill, The only available options when I open Audacity are Core Audio, Built-in Input, 1 or 2 Stereo & Built-in Output.

First confirm that USB AUDIO CODEC 2 is available in System Preferences / Sound / Input.

Then start Audacity and see if it is available as a recording device in Device Toolbar.

I have never heard of a case where an input showed up in System Sound Preferences and was not available in Audacity.

– Bill

Hi Again Bill,
Yes, Codec 1 shows for output & Codec 2 for input on both Sound & Audio Device panes.
I spent 40 minutes yesterday on line with Apple Support. He tried every possible combination of likely settings and checked out my MacBook. He found no fault and came to the conclusion that there maybe is a problem in the Audacity Software or a compatibility issue with the Turntable. I then spoke to Audio-Technica Product Support who are going to send me 2 Videos on setup to see if they might highlight something when I go thro’ those procedures.
Thanks again,

Hello Bill,
I got the videos from Audio-Technica which confirmed the installation & setup were done correctly.
In case I had a faulty download I have deleted & re-installed Audacity 2.2.1 but it has made no difference. System Preferences and AudioMIDISetup all show Codec2 input but Audacity is still not recognising it, only Built-in Input available in Audacity toolbar dropdown box.
Thanks again for your assistance in trying to resolve this problem,

Let’s try resetting Audacity’s preferences.
Go to ~/Library/Application Support/audacity and delete the file “audacity.cfg”. The start Audacity and see if the turntable shows up in the Device Toolbar.
– Bill

Have tried to find where to enter the Go To address you sent me, without success.
Can you give me a clue please.

In the Finder, click on the Go menu and choose “Go to folder…”. In the dialog, type in ~/Library/Application Support/audacity. Don’t miss the “~” character as the start.
– Bill

Hi Bill,
I have come up with a simple temporary solution to the problem. A small ball of Blu-Tak stuck over the mic inlet works wonders! It keeps out all but the loudest shout.
I tried using WavePad which did not pick up the mic, just as a test. I will not be using it though, I prefer the functionality of Audacity.
If we do come up with a solution, the Product Support lads at Audio-Technica U.K. would be pleased to know about it.
Thanks again for your input.
Best Regards,

Hi Again,
Your last msg appeared as I sent my previous one.
Have done as you suggested and put Audacity.cfg in Trash for now, but without effect. Still In-Built Mic only option.
At least thanks to the Blu-Tak I can get on with some recording now.
Have a good week-end.