multitrack recording in XP (Awesome!) what happened in Windows 7/10 ?

I’ve used Audacity for years and am stymied at what is going on with my hardware. Hopefully someone can help.
My goal is to do 4 track simultaneous recording through audacity. Over the years I have tried various laptops and operating systems. I stumbled on a ‘workhorse’ ‘old school’ HP laptop where the internal sound card setup under Windows XP (!) allows multitrack recording. I’ve used it with a Phonic firewire mixer to do 8 tracks at once, I’ve used with a ASUS 4 track USB mixer to do 4 tracks at once (4 mics). Now I’m trying to use a small portable Behringer UMC404HD USB mixer to do 4 mics in a classroom choir setting.

The director had a ‘modern’ laptop running Windows 7 Pro so we started there. With proper drivers for the mixer and the latest Audacity (2.2.2) with up to date drivers on the director’s laptop, Audacity would only allow me to select ‘Behringer 1 and 2’ as an input option or ‘Behringer 3 and 4’ as an input option. That means that 2 microphones are ‘bound’ together in one stereo track and the 3rd and 4th mic inputs are ‘bound’ in one stereo track and i can’t choose both input options simultaneously to get 4 simul tracks.

I’ve tried Windows 10 and the same thing happens. Why would Windows 7 or 10 bind the 1st and 2nd mic input into one stereo track? Why wouldn’t they see 4 inputs and allow audacity to select 1,2,3, or 4 tracks?

I have not taken the choir director’s laptop with its unique sound setup and drivers and revert it back to XP as the laptop is controlled by the school IT folks and we can’t change it.

So then I took my old school laptop running XP which handles the 4 mic inputs as 4 independent tracks and I upgraded the OS to Windows 7. Even though this laptop and sound card setup had worked well, now that it is in Windows 7 we are back to the scenario above where I only get options to have mic 1 and 2 as a single option or mic 3 and 4 as a single option (track). I don’t get it, why would a more modern operating system (Win 7 or 10) break a very awesome functionality?

I’ve watched this forum and many have wanted to use audacity to do multitrack recording on affordable laptops that they already own with low cost mixers. I thought at first it was just the unique sound card setup in this old HP laptop that allowed multitrack recording to work so well for us, but now I’m thinking that if others used XP in their ‘modern’ laptops that maybe this would work for them on a variety of laptops?

Any help is appreciated!

I’ve never tried it.

If you are using an external interface your internal soundcard is not involved (except you might be monitoring through your soundcard).

Since you’ve tried this before, I assume you’ve read [u]Multichannel Recording[/u]?

IMO - Audacity isn’t really designed/optimized for mult-track recording & mixing. And, from what I see on the forums very few people are using it for multi-tracking. If you want to try something else, [u]Cakewalk is now FREE[/u] or there are several popular commercial DAWs.

FYI - The Behringer UMC404HD is a USB audio interface. It’s not a mixer… Any mixing would be done in software.

Most USB mixers only send the stereo-mix to the USB bus. That makes multi-tracking impossible but it makes recording with Audacity easier. There are higher-end mixers that can be used for analog mixing and multi-track recording.

Thanks for the reply Doug, and I apologize about my poor choice of words. Yes, the Behringer is a USB audio interface but has many of the same controls as a mixer (multiple inputs, ability to change frequency and gain of each individual input on the fly and to send a portion or all of the inputs to the output channel(s) like a typical mixer. I chose it because it handles the A/D conversion for me as well and because it is affordable, compact and handles 4 microphone inputs simultaneously.

I’m not good at what happens with hardware/software and audacity and that is why I’m hoping someone can explain.

In Windows XP with the Behringer and my laptop the recording dropdown in 2.2.2 Audacity gives me Behringer 1 channel, or 2 channel, or 3 channel or 4 channel (can’t recall the exact language) but it equals audacity pulling in 1,2,3 or 4 simultaneous tracks which is beautiful.

With same setup in Win 7 or 10 things suddenly change in Audacity and I can only choose line in channel 1 and 2 or line in channel 3 and 4 but no other option to take individual or a setting of input 1-3 or input 1-4. Did Windows mess up the drivers or what is going on?