Multi-channel Flac exports down to 1 channel

Hi all -

I would say I typically don’t have too much trouble with Audacity (version 2.3.0)
I’ve imported a single Flac file, which has 6 channels of discreet audio. In reality, the single file is comprised of 2 songs, but was only tagged as a single song.

My goal is to import the 6 channel Flac file, tag the stops and starts of the 2 songs, which I did…and then export that back into my music folder on my PC. So, it would be export Flac, 6 channels to Flac in my music folder as 2 separate songs.

Only, when I export it and then play in Foobar, it has taken all 6 channels and consolidated into a single channel. In preferences within Audacity, I do have the Import/Export item checked that says “Use Custom Mix” when exporting tracks.

Any suggestions would be awesome…

That should give you 6 tracks in the Audacity project, one above the other. Is that what you see?

With that setting selected, you should see the “Advanced Mixing Options” when you export.

Do you see that?

There should be 6 blue boxes on the left. Is that what you see?

There should be 6 “Channel” boxes on the right. Is that what you see?

Each of the blue boxes on the left should be connected to the corresponding Channel box on the right, like this:


Thanks for your response. Yes, I see the 6 tracks (channels) one on top of the other when I imported the Flac file. No, I do not get to see the 2nd diagram you posted. That’s the part that seems to be missing. I have done this before and had no issues, now I seem to be stumped. :open_mouth:

Check that you do have “Use custom mix” selected.

Is “Show Metadata Tags editor before export” selected? (also in “Preferences > Import/Export”)

Yes for both. So, I followed the link you posted and noticed a comment that says I can’t use Export Multiple, if I have a multi-channel file. Or something to that effect. So, I hi-lited all the channels or tracks and chose Export selected audio, then I could see the diagram you showed…

But doing it that way, it only exported a single file…which is basically what I imported in. I wanted to take the single flac file (with 6 tracks) and place a tag to separate into 2 songs… Maybe I just can’t do that, though I cannot imagine why.

Ah, that explains it.

What you need to do is to select the first song (all 6 tracks) and then “Export Selected Audio”. To do that, zoom out so that you can see the entire project, then click in the top track at the end of the first song, and drag left and down until you have selected the entire first song in all tracks.

After you have exported the first song, hold down the Shift key and click in a track near the beginning. This will grab the start of the selection. While holding down the mouse button, drag to the right so that the entire second song is highlighted (selected). Then “Export Selected Audio” again.

OK, I think that will work. My biggest concern is that the file I currently have, truly is 2 songs. Only, it’s a case where song 1 fades into song 2. Know what I mean? There is no real break. I know where it is…my fear is if I manually create the 2 songs, when I play them as an album in Foobar…it will sound funky. Won’t it? There will be a second where it switches songs, but the constant audio will be disrupted. Does that make sense? I guess I’ll try it and see what happens. If I weren’t so obsessive about such things… :slight_smile: