mp4 files will not load in new version of Audacity

I like to extract audio from mp4 files–downloaded and my own files both. All earlier versions of Audacity that I’ve used would allow me to drag and drop an mp4 video file onto the Audacity window (or allow me to import it) and it would show the waveform and allow me to edit and save or whatever. New version doesn’t do that. I’ve only had luck with audio files. I have had to trash the new Audacity and install an older one (2.0.6) to get this functionality back. Makes no sense. I’ve downloaded the new file twice and got the same result (yes obtained .dmg installer, etc). I love Audacity but if it ain’t broke why’d you change it? I can live with the occasional exported audio file cutting off tracks at 3 minutes (something I haven’t remedied in any version–especially the new one) but this is bordering on ridiculous. I’ll stick with the older version until I read that “legacy” functionality has returned.

John Brune

Which OSX version are you running?

And did you install ffmpeg?

Have a look here:

I had a problem with mp4’s export to m4a too. Turns out one of my experiments corrupted the audacity prefs file. Quitting Audacity and removing the prefs (audacity.cfg) solved the problem. You can find them in:
~/Library/Application Support/audacity/

More info:

Please always give us the exact version number of Audacity (all three numbers) not just say you have the latest version.

As you can see from the sticky topic at the top of this board unfortunately 2.1.0 requires FFmpeg to import MP4 videos. That is already fixed in our source code so it will be fixed in the next 2.1.1 release of Audacity.

If you see that problem again please could you give us steps to reproduce the problem.

Note that if you run out of disk space then exported files will be truncated. If you export WAV or AIFF files Audacity will warn you if the exported audio was not the same as the input audio.