MP3 Playback Crackling Issue

I am using Audacity 2.3.2 on my Macbook with OS X El Capitan (Version 10.11.6).

When I import any .mp3 file into Audacity, playback always results with a crackling sound. I am attempting to edit interviews that I recorded on my phone but the crackling appears in other .mp3 files that I downloaded from the web as well. These same files play without any crackling in Google Music Player or WavePad.

I have tried to change my Audacity preferences by both increasing and decreasing Buffer Length with no success. I have also tried turning off my Wi-Fi and closing all other programs but it hasn’t made a difference. If I create a recording in Audacity using my internal microphone, playback sounds perfect. The same crackling is present when I import uncompressed audio formats as well (.wav and .aiff). I’d appreciate any suggestions to try resolve this error.

See the “Why do I hear clicky playback on Mac?” item on this page:

Thanks for providing that link. I have ensured that I’m using the Built-In Output for playback and I changed the Latency Buffer Length under Preferences → Devices from 0 millisecs to 200 millisecs in 10 millisecond intervals with no effect on the clicking/crackling noises. Is there any other setting that might be affecting the playback?

Bluetooth speakers / headphones sometimes crackle with Audacity - if that’s the problem, then the only solution I’m aware of is to not use those headphones / speakers and used wired headphones / speakers instead.

Thanks. The issue was happening with the internal speakers and I have tried wired headphones but they give the same result. Is it possible to download an older version of Audacity to use on my system since I have not experienced this problem until recently?

Sure. Older versions are available from Audacity’s download partner, Fosshub:

Do let us know the result of your tests.

I downloaded Audacity Version 2.2.2 and opened up the file that was giving me problems. It was still crackling so I changed the buffer length from 100 down to 0 and it seems to have solved the problem. I don’t know enough to know why that made a difference but I’m happy that it did! Thanks for your help!