MP3 files not loading correctly

I have seen several recent previous posts about this same problem. Each time, no one could duplicate it.

This is an HP desktop running Windows 7 64 bit with current patches.

I have been using Audacity 2.0.6 for many months without problem. Suddenly, yesterday when I tried to load any mp3 file, it goes through the progress bar, but there are no waveforms visible. There is just a pair of gray empty tracks where the waveforms should be. When I close Audacity, it asks if I want to save the changes. I say no.

I tried several mp3 files that I had successfully loaded a month ago, and they won’t load now. All my mp3 files are from a Tascam digital audio recorder that has worked successfully for at least 8 months with Audacity.

I can play the mp3 files in Windows Media Player so I know there is content in them.

I can still open an existing Audacity project aup file and see the waveforms.

I updated to Audacity 2.1.1, but nothing changed with this problem.

I still have Audacity 2.0.6 on my laptop, and it will correctly load the same mp3 files that fail to load on my desktop. The laptop has essentially the same apps and environment as the desktop, yet Audacity works on the laptop and not on the desktop.

I think something has changed about the environment on my HP - maybe some recent Windows patch? I have recently installed Malwarebytes on both the desktop and the laptop, so that probably is not the cause.

I re-installed Audacity 2.0.6 on the desktop, but that didn’t change the problem.

Any suggestions?


Could you please give those examples? Might you be thinking of MP4 files on OS X: That one is an Audacity problem but it is now fixed.

Does Help > Show Log… think the files imported?

Does pressing SPACE play the invisible files?

You could try a system restore back to the point before the problem started.


here is one post, I found others with various searches that I can’t recall now:

Show log returns an empty log. Space does not play the mp3. There are no indications of any signal - there are no waveforms of audio on the display. Just a flat blue line.

I don’t know when the problem started. I haven’t used Audacity for about a month, and a lot has changed since then, so I am in the dark about doing a system restore.

Seems like since others have been reporting this problem since April, someone might have an idea about it.

What next?


I have seen several recent previous posts about this same problem. Each time, no one could duplicate it.

Can you point us to these posts? Audacity 2.0.6 and Win7 is one of the successful combinations. That’s what’s causing all the raised eyebrows.

I was going to ask you if previously successful MP3 files opened now.

And just to cover it, can you still configure Windows to show you all the filename extensions? It used to look like this:

Hidden File Extensions - Windows
– Start > My Computer > Tools > Folder Options > View > [ ] Hide Extensions for Known File Types (deselect)
– Apply (to this folder) or Apply to All Folders
– OK

Also, there is a testing tool called MediaInfo, but there’s something magic about downloading it.

To a Windows person missing filename extensions, all sound files are MP3, whether they actually are or not.


That is a Mac post, not Windows. There are a number of Audacity Mac problems. Apple decided to include extreme power saving for its product line and it created a number of destructive problems.

“We perceive you’re not doing anything important just now, so we’re going to shut the processor down for a few milliseconds. That’s not a problem, is it?”


I can well imagine a pitched battle between the usability folks and the efficiency folks. The well-designed rotating backup icon is now an easy-to-miss, tiny, non-animated graphic.


To bring this around, the super bad news is you may have a one-off computer problem.


I can still open an existing Audacity project aup file and see the waveforms.

And hear it? Shouldn’t leave out any steps. The blue waves and the sound come from different places. That’s why Gale asked you if you could hear the work in the absence of the waves.


I think I solved the problem, but I don’t understand it exactly.

After I failed to open the .mp3, I looked at the log, and saw this:

8:14:48 PM: Audacity 2.0.6
8:14:48 PM: Log Cleared.
8:14:59 PM: File name is C:\Church recordings\building dedication & wendy installation 9-15\building dedication.mp3
8:14:59 PM: Mime type is *
8:14:59 PM: Opening with libsndfile
8:14:59 PM: Opening with libmad
8:14:59 PM: Open(C:\Church recordings\building dedication & wendy installation 9-15\building dedication.mp3) succeeded
8:14:59 PM: Error: Directory 'C:\Users\JOHNDE~1\AppData\Local\Temp\audacity_1_2_temp\project31272' couldn't be created (error 5: access is denied.)
8:14:59 PM: Error: mkdir in DirManager::MakeBlockFilePath failed. (error 5: access is denied.)
8:14:59 PM: Error: Can not enumerate files in directory 'C:\Users\JOHNDE~1\AppData\Local\Temp\audacity_1_2_temp\project31272\e00\d00\' (error 3: the system cannot find the path specified.)
8:14:59 PM: Error: can't open file 'C:\Users\JOHNDE~1\AppData\Local\Temp\audacity_1_2_temp\project31272\e00\d00\' (error 3: the system cannot find the path specified.

This told me that no project file was found, so I closed Audacity, re-opened Audacity, and immediately created a project. Then I opened the .mp3 file in that project, and it works OK now. I can see the waveform, and hear the audio.

What I don’t understand is that always before I have been opening the .mp3 first, without creating a project, then saving a project later. For whatever reason, this doesn’t work now.

Sorry about the confusion, I guess.


8:14:59 PM: Error: Directory ‘C:\Users\JOHNDE~1\AppData\Local\Temp\audacity_1_2_temp\project31272’ couldn’t be created (error 5: access is denied.)

This seems to suggest you don’t have permission to create new work in that directory. Audacity has to make a personal copy of the music you’re trying to open. If it can’t do that, then the show is damaged.

I’m in fuzzy water here, but If you create a Project and save the project on the desktop, then Audacity will do all its work on the desktop which you clearly have permission to use.

Someone will correct me.


The point about MediaInfo is that they have been known to bundle other software in their installer and may install the other software even if you ask not to.

To be sure not to harm your computer you should get the version without installer, which is fine.


That describes the problem better. The flat blue line is an Audacity track. We thought there was no track created.

It tells you Audacity cannot write to “'C:\Users\JOHNDE~1\AppData\Local\Temp\audacity_1_2_temp”, probably because of confusion with the tilde (~) in the name of the directory.

Your user folder is not actually “JOHNDE~1” if you look at it in Explorer. That name is the shortened 8.3 filename that Windows uses for compatibility with old applications.

Did you go back to an old version of Audacity at some stage that creates the “audacity_1_2_temp” in the name of the temp folder?

You will probably have the same problem again if you don’t save a project first.

The easiest way to fix this is to reinstall Audacity (ideally the latest Audacity 2.1.1 from and enable the “Reset Preferences” box half way through the installation. Then when you launch Audacity, confirm you want to reset preferences.

This should reset the Audacity temporary directory to “C:\Users<your user name>\AppData\Local\Temp\audacity_temp”.


you should get the version without installer, which is fine.

How, in that blizzard of graphics, would I do that?

Look on for the links that say “without installer”.


On my desktop machine I looked at the permissions for the audacity_1_2_temp folder, and I did not have anything but read access. I changed the folder to full control, and things seem to be working normally again with opening mp3 files Audacity.

The odd thing about this problem is that on my laptop Audacity 2.0.3 is using audacity_temp, and that folder only has read access as well. But I can open mp3 files on this laptop without problem. I have the same anti-virus and anti-malware software on both machines, so something else must also be going on.

This is a deeper problem than I understand, but at least I can function again. But it makes me nervous when a problem goes away and you don’t fully understand why.

It would have been helpful if an error message could have been generated when the mp3 could not be written to the temp folder. It was in the log, but most people probably don’t know to check the log when an error occurs. I didn’t.

From some searches on Google I see that some antivirus programs lock down temp folders so that malware can’t execute from them. I didn’t find any settings for this in AVG Free or in Malwarebytes. I don’t know if this is what happened, but the Audacity developers might want to look into changing the default directory for storing project data if this is indeed the case.

I realize that every Windows machine is different, but I am pretty much in the mainstream with what I do on these machines. If I am having this problem, surely someone else is also having the same problem.

Thanks for your help.


I have no idea why Audacity was using audacity_1_2_temp. I have never touched the directory settings. I also had audacity_temp as a folder.

I uninstalled 2.0.6, and installed 2.1.1, resetting preferences.

When I tried to open an mp3 file, the same flat blue line appeared.

The log showed that permission was denied for audacity_temp. I reset the permissions to full control for audacity_temp, and now I can open mp3 files.

I wonder what is causing these temp files to be read only?

Does the audacity_temp directory on the laptop have the tilde-shortened name for your users folder?

I agree and the developers know, but this is not as easy as it might seem because the error messages in the log are generated not by Audacity but by the “wxWidgets interface toolkit” we build Audacity with.

I use Malwarebytes free AntiVirus and AntiExploit, and I know those do not change permissions on temp folders.

Some antivirus apps do monitor and scan temp directories, which can lead to dropouts when recording in Audacity.

Some antivirus apps and clean up tools regularly delete the contents of temp folders. Norton does that by default.

I have tried setting audacity_1_2_temp 8.3 filename tempdir paths in our current Audacity code, but never found that Audacity cannot write there. But occasionally those legacy paths have caused problems in older 2.x versions of Audacity.


The laptop does not have the tilde shortened name in the directory path. But the new install of 2.1.1 on the desktop still has the tilde shortened name in the path.

As I said, you probably used an older version of Audacity at some time.

According to Directories Preferences, what is the exact temporary directory shown there?

Assuming you checked the exact same folder for the exact same Group/user name, we can’t tell you that. You could look in the Event Logs perhaps.

Is the account you are logged in as an administrator account?

Whatever the issue, the answer is probably to open Directories Preferences and type in a folder path that does not have “temp” in its name.

For example, try creating a folder called “audacity” in the location where you save your projects to. Copy the path to that folder from the Explorer address bar, then paste it into the “Location:” text box in Directories Preferences.

That way, Audacity won’t add “audacity_temp” to the folder name.


I suspected the tilde-shortened name is at least part of the problem.

I don’t know why the reset of preferences would still create the shortened name. I will try it some time with an account with a long user name.

Meantime I propose you follow the suggestion I just made to paste a path into Directories Preferences that is a newly created folder (not including “temp” in its name) that is in the location you can save projects to.



I changed the name of my computer to only have 8 characters, no spaces. That should stop the tilde problem in file names.

Then I created a new Audacity work folder where I store my recordings. After resetting the directory path in Audacity 2.1.1, things seem to be working OK for now.

Thanks for your help in getting me going again! Maybe my experience can benefit someone else down the line.