Motion LE1700 tablet PC


I have tried all possible inputs and none will return a sound signal. I am running Audacity Beta 1.3 (Unicode) on Windows7 Ultimate. The notebook is a Motion LE1700 tablet PC. It has integrated microphones.

Skype will find the microphone as “microphone (High definition audio device 3)”.

I have my own audio program (SonasoundP on sourceforge) and it finds the audio on “Microsoft sound mapper output”. That name comes from PortAudio19.

I have already searched this forum and the Net without success to far.

If I plug in a USB headset, Audacity will find the headset microphone. The problem is that the headset stays at home and I wish to record while I am at school.

I have no problem using Audacity on my Linux box.

Thank you for any clue.


What options are available in “Edit menu > Preferences > Devices” for “Host” and for “Recording” and “Playback” devices?
Which options are currently selected?

Note that Skype is incompatible with Audacity and must be totally shut down before you open Audacity (not even running in the background).

Host: MME and WindowsDirectSound.
With MME, “Microphone Sound Mapper - Input” and four times “Microphone (High Definition Audio”.
With WindowsDirectSound, “Primary Sound Capture Driver” and 4 times “Microphone (High Definition Audio Device)”.
This is an array microphone: there are three microphones working together.

With MME, “Microphone Sound Mapper - Output” and “Speakers (High Definition Audio”.
With WindowsDirectSound, “Primary Sound Driver” and “Speakers (High Definition Audio Device)”.

I have tried all.

Skype is typically off, not even working in the background. No other audio program running.

I have also looked at all combinations of parameters in the Windows Sound window under the Recording tab.


Do you mean “Microsoft Sound Mapper”?

How strange…
Do you have any information about that?
Is there some sort of “control panel” for the sound card?
What does the manual say regarding recording from the microphone?

Hi, Steve,

Thank you for your patience.

Right, that’s my mistake.

I was looking for such a panel but found nothing, but your question forces me to look again at the Motion support site.

I feel a bit stupid. :astonished: Indeed, I had not installed the IDT sound driver. Now, I just installed the driver, and the problem is solved :slight_smile: .

The devices are now,
Microsoft Sound Mapper - Input, Microphone Array (IDT High Defi…, Dock Mic (IDT High Defi…, External Mic (IDT High Defi…

Explanation. The prior owner of the Tablet installed Windows7 but didn’t install the IDT driver.

I found it strange that Sonasound got its input from “Microsoft Sound Mapper - Output”, but that worked. Now it’s makes more sense .

Not at all, if you hadn’t mentioned that it has an array of microphones we would have been chasing this problem much longer. The microphone array idea is unusual, hence requiring a special driver, and spotting the fact that the special driver was missing is not obvious until you start looking more deeply into the matter.

Here is a copy of my notes, which I saved as I don’t want to experience the frustration again. I hope you find the steps helpful.

  1. Start → Control Panel → Sound → Recording tab.

  2. Right-click in blank area of the panel → make sure
    both “Show Disabled Devices” and “Show Disconnected
    Devices” are checked.

  3. Right-click on "Integrated Mic Array → Disable.

  4. Right-click on “External Mic” → Enable (a check sign
    on a green button should appear on the External Mic

  5. Right-click on External Mic → Properties → General
    tab → make sure “Use this device” appears in “Device
    usage” box.

  6. Levels tab → set “External Mic” to 0 → and make
    sure speaker icon is enabled <)) → set Microphone
    boost to +20.0 dB or < (launch Audacity: if mic
    proves too hot, lower boost to +10.0 dB).

  7. Advanced tab → select default format as “2 channel,
    16 bit, 41000 Hz (Studio Quality).”

NOTE: Choose 24 bit if your soundcard and software
supports it.

  1. Plug in an external microphone into the soundcard of
    your PC.

NOTE: Some microphones, like the CO2 condenser type
require phantom power. In such case, you will
need to firstly plug the mic into a mixing
board with phantom power then connect the
output channel of the mixer to your PC’s mic

  1. Recording tab → speak into the microphone. You
    should see a green signal appear in the meter to the
    right of “External Mic”; if not, follow steps below:

Option #1: Start → type in “troubleshooting” →
select “Troubleshooting” from the list above →
under H’ware & Sound, click “Troubleshoot audio
recording” → Next → select the device you wish
to troubleshoot → Next → Apply this fix.

Option #2: launch Windows’ “Sound Recorder” → press
F1 key (or click “Help”) → scroll to bottom →
select "Troubleshoot audio-recording problems →
“Fix it” → Run (to download and run a Microsoft
app called “Mats_Run.AudioRecording.exe”) →
install the app → Run → “Detect and apply the
fixes…” → select to troubleshoot “Microphone”
→ Next → Close. If problem still persists, try
your notebook mfr’s forum.

Option #3: Start → type Device → Device Manager
→ expand "Sound, video and game controllers →
right-click on any duplicates and Remove → Action
→ Scan for haedware changes → exit.

  1. Apply → OK → exit.

  2. Browse to Volume Mixer (as Administrator).


  1. Make sure all the options are enabled (icon below
    each Device and Application appears as <))

  2. Set all the faders to “0” (to avoid feedback) → Exit.

  3. Launch Vista’s “Sound Recorder” (default save is .WMA)
    or installed software, like Audacity and begin recording.

NOTE: Approximate .WAV file size for 5" of recording
at 96 KBps = 51 MB. The same recording in .WMA
format = 3.5 MB.

As this involves a rather unusual hardware set-up, I’ve moved it to the “Recording Equipment” section and changed the topic title so that it will hopefully be easier to find for people with similar hardware.