more tracks = sustain/sound problem?

Hello everyone, I have a problem when I there are more tracks.
I record my 88 keys keyboard in audacity with an audio interface (focusrite forte). The sound is great but unfortunately when there are more than 1 track my piano sounds blocky and less sustain :s. Even when I use the click track as a metronom the same happens… This is a huge problem because I overdub a lot =/

Can someone tell me what I can do about this ?

Please look at the pink panel at the top of the page and answer the questions.

Have a look at Audacity Manual (everything after the first two paragraphs). You may have mismatched sample rates between the Audacity track and project rate, or between Audacity, Windows and Focusrite.


Alright I will check it out! Thanks for the quick reply.

But altough I didn’t change anything on the settings .

Thanks for the quick reply, I always record in sample rate of 48000 khz because i use my recorded music to sync with the video.
To avoid misunderstandings, the first track I play sounds crystal clear and without sustain problems, when I make another track (overdubbing) then the strange problem happens.

I don’t know if this applies to “blocky” and “less sustain”, but you can get distortion when mixing. But, that might not be your problem because “overload distortion” usually gives you more sustain, because clipping is a kind of dynamic compression.

This is a huge problem because I overdub a lot

Mixing is done by addition… Analog mixers are built around analog summing amplifiers. If you mix two or more 0dB normalized (maximized) tracks you’ll get [u]clipping[/u] (distorted flat-topped waves). Audacity itself uses 32-bit floating-point so it won’t clip internally, but your rendered file or your digital-to-analog converter, etc., can clip.

Pros often record at around -18dB to allow headroom for unexpected peaks, mixing, effects, etc.

You still have not told us your version of Audacity and Windows. :wink: We can’t help properly without full information to go on.

Then you must check that Windows and Focusrite are also both set to 48000 Hz, or you may get poor sound quality. Assuming you are on Vista or later, either choose MME host in Audacity’s Device Toolbar and set Default Format to 48000 Hz for Focusrite recording in Windows Sound, or choose Windows DirectSound host in Audacity and turn both Exclusive Mode boxes on for Focusrite recording in Windows Sound.

If you have Transport > Software Playthrough turned on in Audacity, turn it off and monitor yourself only in Focusrite.


I reïnstalled audacity so i think i have the latest version. My system is windows 8.1 =)
Thanks for the helping guys!

If you look at Help > About Audacity… and it says 2.0.6, you have the latest.


yes it has 2.0.6. In windows I have with “recording” and “play” 48000 khz.
In audacity I have 48000 khz and in focusrite forte software 48000 khz too. Hmm very strange. And the fact that the first track sounds crystal clear makes it even more strange.

I think we will need to get into the details…

Please describe in detail exactly what is plugged into what (make and model numbers may be important).

Please post a couple of short audio sample (4 or 5 seconds each, in WAV format) to illustrate what you mean.
Please include one “sounds great” single track recording, and one “sounds blocky and less sustain” example.
See here for how to post an audio sample to the forum:

Thanks for checking. Have you tried also Windows DirectSound in Audacity’s Device Toolbar then both Exclusive Mode boxes ticked in Windows Sound’s Record and Playback for Focusrite? Then we can probably be sure it is not a sample rate mismatch.


Ok, to start with, this is my focusrite forte

this are the audio outputs of my keyboard, they go to the line in of my focusrite forte (I record in stereo)

these are the line/instrument in’s of my focusrite forte.

and these are the Yamaha studio monitors

I hear myself playing because the line out of my keyboard goes to the line in of my focusrite, then the line outputs of my focusrite goes right in my wall wich is attached to my studiomonitors. Well thats quite the way I work.

And I got the two samples too :slight_smile:

Oh and my host is MME for now because I have Installed my latency correction there in “preferences” and everything is in 48000 khz, in windows, audacity and focusrite.

the both boxes are selected as “focusrite” if that is what you mean but when I record the second track I already hear the sustain “blocky” sound while I’m playing the song, not only when I play it back :confused:

The “blocky” sample has no useful audio above 3000 Hz (compared to about 5500 Hz in the “good” sample) so obviously sounds dull.

MME is 44100 Hz only so that guarantees resampling will occur if you have everything else set to 48000 Hz.

I don’t know if resampling is the problem, but to prevent resampling, choose Windows DirectSound host in Audacity and enable both Exclusive Mode boxes for Focusrite Recording and for Focusrite playback in Windows Sound.


I mean what I said the first time :wink:

Set both Exclusive Mode boxes “on” for Focusrite playback and for Focusrite recording in Windows Sound. Those boxes are underneath where you look at Default Format:
So, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Focusrite then choose “Properties”. Then click the “Advanced” tab and you will see an image like the above. Put a tick in both Exclusive Mode boxes then OK.

Now click the Playback tab. Right-click over the Focusrite then choose “Properties”. Then click the “Advanced” tab and put a tick in both Exclusive Mode boxes then OK.

Then choose Windows DirectSound in Audacity Device Toolbar.


Oh alright? Because I Always select in audacity “48000” kHz?
The reason why I choose for MME is because I already set my latency correction in recording preferences and since windows direct host is a littlebit faster I have to recheck that.
Yesterday I’ve tried windows direct sound but the same problem occurs :frowning:

Thanks for all the helping !
But I never touched that boxes so they were Always on ;/ I don’t think that the samplerate is the problem

And if it was the problem then I think I already had “blocky” sound in the first track.

What is the make and model number of the keyboard?

Are you recording as you play, or playing a saved MIDI file?