Mono only for USB Audio-Technica turntable

I have had no success getting playback or recording of records on my Audio-Technica AT-LP120-USB turntable on my MacBook Pro (Sonoma 14.2.1) using Audacity 3.4.2.

I have my Playback to MacBook Pro Speakers, Recording Device is USB AUDIO CODEC with 2 Channels (stereo).

I’m unable to get anything other than the left channel. Can anyone help me with this?

I’m a Windows guy and on Windows BOTH Windows and Audacity have to be set for stereo.

There’s probably a MacOS mono/stereo setting, but if you can’t find it someone else will have to help.

And if you have something to plug the turntable’s analog outputs into (a stereo system, or maybe your TV), it’s worth checking to make sure both channels are working. If the right channel is missing from the analog, the USB isn’t going to work properly either.

Thanks! I’ll have a look into both those suggestions.

I managed to plug the turntable into an AVR and confirmed that using the RCA jacks I got stereo sound. So it’s only happening via USB. I’m stumped!

Audacity 3.4.2 does not work with Sonoma 14.2, it does work with Sonoma 14.1.
Notice that you don’t have any record levels, and that the levels are L/F instead of L/R.
Other posts have stated that this will be fixed with Audacity 3.5 when it comes out.
Additionally, I noticed last week that on a Mac Mini with Sonoma 14.2.1 that in the audio settings only mono was showing.
So, it would appear that there are audio setting problems with Sonoma 14.2.1, and those problems may or may not be causing the problems with Audacity.
We probably will have to wait for both Sonoma 14.3 and Audacity 3.5 for a fix.
I also use Audacity to record from an AT-LP120, and everything worked fine until I upgraded from Sonoma 14.1 to 14.2.
New poster here, created an account to let staticfan know the source of the problem.

Audacity 3.4.2 now works in Sonoma 14.3.

Thanks so much for sharing this info. I’m upgrading to Sonoma 14.3 tonight and will test it out tomorrow.

This is weird. I’m still not getting stereo, but the channel bars are active. The right channel has a ~50% signal but I’m not seeing/hearing it when I record. Any suggestions?

Not sure. Click on the audio settings button and see what it shows.
In Audacity menu bar (I’m not looking at it, so guessing how it looks), might be under View, there is a way to have the audio settings displayed in the Audacity window.

Also, on the Mac menu bar Go>Utilities>Midi settings.
Check the settings for Mac audio.

Maybe try reinstalling Audacity.

Did everything work fine before Sonoma 14.2.1, or have you just started trying to do this? Maybe the AudioTechnica USB cable is defective?

This topic was automatically closed after 30 days. New replies are no longer allowed.