Monitoring recording

Audacity 2.4.2 on Mac 10.14.6.

I am recording audio streaming on the web, and have been doing it for almost 5 years. My issue now is that, while I am able to record and monitor the recording, I have no volume control over the monitored output. This seems to be something I lose periodically and then after restarts and/or reboots I get it back – but not this time. The whole subject of input and output devices has always been confusing to me, but I muddle through. In any case, my input to audacity is iShowUCapture and my output is an aggregate device combining iShowUCapture and built-in output.

iShowYouDevice has no direct output control, but I have been able to control it through sound preferences, by adjusting the output volume on the input device. And this setting is reflected in the volume dropdown in the top menu bar. It just doesn’t actually do anything. And I haven’t changed any settings recently.

I was hoping one our macOS elves would pop in here, but until they do, perhaps you can be inspired by this post:

Thanks, but the audacity volume control doesn’t work either.

It’s funny but I get into this stuff sometimes and lose all track of my context. It was New Year’s Eve and I’m running up a Help! flag on a technical forum. On New Year’s Day our sump pump failed in heavy rains. Now THAT was an emergency.

I’m thinking now this is a Mac issue and I am going to have to do some special reboots, to reset SMC and NVRAM. I’m sure that’s what Apple Support would recommend. Although, to be honest, these didn’t work last time this happened.

EDIT: Hold the presses! It does work (for now anyway). I went into audacity preferences and selected built-in output for my playback device, and now it seems I can use the audacity playback volume slider without effecting the recording level. I’ll have to work with it for a while – but now I’m wondering why I went to the trouble of creating an aggregate output device. That’s not something I would have come up with on my own.

Thanks again.

:smiley: Thanks for reporting back. I’m glad you got it working (for now anyway). :wink: