monitor/recording freezes immediately

I am on a Microsoft Surface Pro 3 running Windows 8 and trying to record/digitize vinyl via the HRT Linestreamer Plus converter device. VPI turntable, Grado cartridge, Clear Audio phone stage.
I have successfully done this on a previous computer, but am struggling with the SP3.
I get all set up and when I click on the monitor I get about 1 sec of monitoring and then it stops. Same thing if I try to record.
I have aligned the HRT with audacity at 44.1 but don’t understand why this won’t work. I also have a Lenovo workbook running Windows 8 and the same thing happens.
Can anyone help?

It’s probably a USB transmission or buffering problem.

Plug the HRT into an empty USB port. Do not plug it into a USB hub attached to the port. Restart the computer.

If the issue persists, open Edit > Preferences…, look in the Recording section and make sure Audio to buffer is at 100 milliseconds or higher. Change the USB cable if necessary, and make sure it fits tightly both ends.


The USB was always directly in the SP3, no USB hub in use.
I re-started the SP3 with the USB attached with no success.
I bought a new USB from Radio Shack (the original was AudioQuest Cinnamon…good quality) with no change.
And I ensured that the recording buffering latencies were >/= 100 msec (I increased the latency to 125msec).
I did this for both the SP3 and the Lenovo ThinkPad.
On the HRT, 44.1 is illuminated, so that seems to be correct.
The only change is that I get zero signal when I try to monitor with the Lenovo. When I try to record with the Lenovo, I get zero signal, however the vertical tracking line flashes.
With the SP3 I get the same response as previously, about 1 sec of monitoring before cutting out, about 1 sec of recording, then cutting out.
If I open a second file with the SP3 I get the same monitoring response as the first file, but when I try to record it looks like the Lenovo, i.e., zero recording with the vertical tracer flashing.
On both machines the record button stays depressed when I attempt to record.
I am fresh out of ideas…

Use the latest 2.0.6 version of Audacity (see the pink panel at the top of the page).

Make sure that Transport > Sound Activated Recording is off (no tick or checkmark).

See if turning Transport > Software Playthrough off helps (no tick or checkmark). You won’t be able to hear what you are recording but at least you will know if that is a solution.

Choose MME host in Audacity’s Device Toolbar.

Don’t forget to change the USB cable. USB cables supplied with USB audio devices are sometimes faulty.

Make the USB device you want to use Default Device in Windows Sound then try recording with Windows Sound Recorder. If that stalls too, then the problem is not caused by Audacity.


Did all this stuff and no changes.
However, I tried recording with my wife’s MacBook, running Yosemite, and everything worked very well.
So I’m guessing there is some problem for me between the LineStreamer and windows 8…I will email HRT and try to see if anyone else has had this problem.
Thank you for your help.

Hi mkat.
Just like to report that I am having a very similar experience.
In my case:

  • -I have had the Linestreamer for just over a year.
    -I have been using it in that time with Audacity on Opensuse linux without issue.
    -On my Microsoft Surface Pro 3 (Core I5 8GB RAM) running windows 8.1 with all current updates I’ve just installed Audacity 2.06, and like mkat Audacity freezes after appearing to record for about a second.

Testing the things I can think of to test:

  • -I tried all of Gale’s suggestions (thanks!)
    -I have done a fresh Audacity install on a spare machine (lower powered Core I5 4GB RAM) , and it records perfectly from the linestreamer
    -If I connect the Linestreamer to a linux instance running in Virtualbox, the linux version of audacity records in a visibly normal manner (there is some audio distortion, but may be fixable with settings).
    -Windows Sound Recorder also seems to capture about a second of audio.

These make me think that the problem is somewhere between Windows on the Surface Pro 3 and the Linestreamer : that is possibly not caused by Audacity, more likely another of the quirks with the Surface Pro 3…

If you’re still following this thread, have you contacted HRT with any success?
-I’ve also cross-posted over at

Just a further note to mkat if you’re out there:
I just tried to do a firmware update ex. the tools on HRTs site, which seemed logical to try as the device has no Windows drivers.
Unfortunately it bricked the device, so I can’t use it with Audacity on anything now. :cry:

I encountered precisely this issue with my Asus laptop running Windows 8.1 with 2 USB 3.0 ports and no USB 2.0 ones.

It appears the Linestreamer had an issue with running under this config. I went into the BIOS settings and under the Advanced tab, there is the XHCI Pre-Boot mode setting. I set this to “Disabled”, which apparently makes the USB ports function like USB 2.0 ones. After rebooting, I got things working as expected.

Hope this helps :slight_smile:

Many thanks for your tip, markym3.

There is a bit more about these settings here