"Modify>rename clip" fails (Audacity 3.2.2)

Sorry, may be I am in the wrong place, but just registered.
I’m using Mac OS Monterey 12.6.
AU 3.2.2 has a possible bug in the rename clip command: if you click on the name or if you do try to do that through “Modify>rename clip” it doesn’t work and Au start playing. You can rename only if you do: preferences>keyboard>rename clip>set (I ma not sure the English for the Italian Imposta is set).
The bad point is that also if you do that and you change the name, the following time you have to follow once again the same procedure. It doesn’t keep the change in its preferences’ memory.
I think this should be corrected.

I am unable to duplicate this issue on my Windows machine. Perhaps someone else running MacOS can.

So on my Windows machine, “Modify>rename clip” would be “Edit>Rename clip”. On my machine, Ctrl+F2 does the same thing (which would be preferences>keyboard>rename clip>set)

To rename a clip, you could also try double-clicking on the clip title bar or right-clicking on the clip below the title bar.

This sounds very convoluted. Would you like to clarify?

Also note, there is an outstanding intermittent problem with renaming clips not working properly. See: Can’t rename clips #3704

I don’t know if this is the same issue you are having, but for that issue there is a workaround (which does not seem to make any sense): "In the Track behaviors section of preferences, set “use dialog for the name of a new label”.

Yesss! this worked for me! Thank you!!! First time looking something up in a Forum actually worked for me. :laughing:
‘In the Track behaviors section of preferences, set “use dialog for the name of a new label”.’
Big Sur 11.7.4, Audacity 3.2.4