Mixing with Noise, ACX compliance & mp3 issues

Using 3.42. So, I recorded a few chapters of my upcoming Audible. My MO was to make track one my narration, and make it as cleanly compressed as possible and ACX compliant. Then, as there would be almost no noise, I would add a very low noise floor to track two. I would mix and render this into a new track, which simply overlaid the noise onto the ACX compliant track one. I would double check, and this new mix would invariably still be compliant. Then I would export to mp3, load that up to test it, and the mp3 would be compliant.

Now, all of the sudden, when Audacity mixes, it lowers the volume of track one because track two is barely audible noise. So the mixed result is too quiet, and no longer compliant. I have tried correcting this by turning up the gain 2 decibels on track one before mixing. The result is ACX compliant, although no longer evenly compressed as it was before and ridiculously off for merely adding a tiny bit of noise. However, when I export that compliant track to mp3 and reload it to check, that new mp3 is somehow too quiet and not compliant! I have no idea what changed in Audacity or if there is a setting or whatever that I missed. Any help would be appreciated.

UPDATE - The problem was that I had a real time effect still running. Thanks to all for your help!

Mixing-in noise at -65 or -70dB shouldn’t affect anything else. But you don’t normally need to add noise unless you’ve used “excessive” noise reduction or noise gating, or if you added sections of pure-digital silence, or maybe if you are recording in a pro soundproof studio.

If you need to add noise that should be done last because any adjustments after that will change the noise floor.

Search the forum for “ACX Macro”.
It applies RMS normalization at -20dB which nails the RMS requirement. Usually that pushes the peaks up out of compliance. Since it’s normally a boost, it also increases noise.

Then it runs limiting at -3.5dB, putting the peaks into compliance with almost no effect on the RMS level. Your peaks & RMS levels should pass every time, but now you may have to deal with the noise floor.

…There was an identical manual mastering procedure in the Wiki but they killed the Wiki.

I’m not sure what that means. Compression (including limiting) ALWAYS makes the signal-to-noise ratio WORSE. Then make-up gain (or any gain) brings-up the noise floor.

MP3 compression (file compression is not dynamic compression) often boosts the peaks a little but it should have (almost) no effect on the RMS level. The ACX spec is -3dB so setting the limiter to -3.5dB allows 1/2 dB for that.

Your posting just screams other software on your machine that’s “helping you” record your voice. Further, the latest problems may have more than one.

Nobody should have to surgically add noise to their live recordings.

Do you use Skype, Zoom, Meetings or other communications software or Games? All these programs force-configure voice processing in the background. Make sure they’re all completely off and not hiding in the background.

Sometimes, these programs will leave sound processing running even after you turn them completely off. Shut down and restart your Mac or Clean Shutdown your Windows machine…

Shift+Shutdown > OK > Wait > Start.

…to get rid of that.

ACX-Check is one of the two applications for Audiobooks. Audiobook Mastering Macro is the other one.

Mastering will take a raw recording and give guaranteed Peak and RMS (Loudness). If you recorded in a quiet, echo-free room, that may be all you need.

No additional noise track necessary.


You didn’t say which machine you’re on, but if it’s Windows, Windows Setups (Enhancements) can have sound processing, too. Make sure that’s completely off.

One recent posting turned up another place Windows can add sound management, but I didn’t write it down.


Audacity3 can have a realtime plugin running in the background,
its effect only becoming visible on mix-down.
i.e. check realtime plugins are off.

hidden compressor plugin is on

1 Like

Thank you - this was the problem!

This topic was automatically closed after 30 days. New replies are no longer allowed.