Missing the < and > on audacity horizontal scrollbar

Hi, I have Ubuntu Studio 19.10 and 20.04, with Audacity 2.4.2 from the distro’s repository

I need to know how to get an Audacity with the < and > controls on the horizontal scrollbar,
to move through the waveform when zoomed in. I realize this may mean using an older Audacity,
older wxgtk things, different window-manager etc, all fine by me. Typical workarounds are not useful
for what I do. I have many older .deb versions in back-up folders, and room for another distro
with libs that include the < and > if that is the best solution.

The windows version in wine has the < and > so it works for visual edits, but there is no text in the fields to select
the audio device, so maybe there is a font missing, but have no such occurence in other wine-based win apps.
Any tips greatly appreciated!

The scrollbar is provided by your window manager. Depending on your window manager, you may be able to change the scrollbar style by using a different Desktop theme.

I installed some themes and window-managers, and a theme switcher, but didn’t get lucky (yet)
But I found a live dvd of Puppy Studio 1337, that I have savefiles for, and the first one I tried,
contained Audacity with the < and >

It uses JVM windowmanager by default, and it’s repository uses ubuntu Bionic.
Hopefully some people here will have other setups to report.

This is with Xfce desktop:


Thanks for that, I have thunar installed in each distro, so adding the rest of xfce will only be a few k more,
and I then I can switch to or boot xfce sessions. :sunglasses:

I installed the xfce meta package in MX Linux, and logged in to
an xfce session, and audacity didn’t display the <>

Is your xfce based on a distro where it is the default UI?


Xubuntu 18.04 LTS

According to this post there is a setting in gtk3 which decides whether to show the arrows (scrollbar steppers) or not:


Thanks for posting that! I now have the < and >
but the cursor advance speed is so slow it’s beyond useless.

For example, if I select one second of audio, and want to advance the view
left or right, when pressing the related widget, the speed is too slow to be of any use.
Same in Ubuntu Studio 19.10, and 20.04.

In windows audacity in wine 5 stable or wine staging 5.10 or 5.16, the cursor
speed is as expected, and suitable for edits. Google searches so far relate
to cursor speed during playback, rather that while editing.
Progress, nonetheless.


There a function called gtk_adjustment_set_step_increment

not sure if this is the right one or if it can be configured by user

It could be worth asking on the Gnome Core forum (Gnome look after GTK development).


Also, probably not what you want but you can scroll in steps using + mouse wheel.

Thanks for the tips! I tried that, and it does work as presented. I think the zoom function needs some
linkage to how fast the scrollbars can move the cursor, so that a cursor present in deep zooming can be moved
slowly relative to the current screen boundaries of the waveform view. Seems like a regression
somewhere among the audacity dependencies. I’ve tried two Puppy linux distros from different
maintainers, each with 2.2x audacity versions, and JVM window manager, and they work as expected
(like the windows version) and there’s nothing special in .config/gtk-3.0.

Hopefully some config info will appear for the major window managers.
I’ll check out the gnome site you mention

No, it’s a “feature” of the Desktop environment - the scrollbar is a “native” control, hence why it changes when you use a different Desktop environment. It really has very little to do with Audacity, other than the fact that Audacity tells the system to add a scrollbar.

If you want to scroll faster, zoom out a bit (https://manual.audacityteam.org/man/zooming.html)

Something provided by dependencies that worked three years ago, and now has stopped working is ‘a feature’?

The issue for me is two-fold: precision edits, and control of the cursor. When using a window manager
that lacks the < and > if you are zoomed in for precise edits, using the scrollbar is not an option,
you’ll loose your place and/or selection instantly, and arrow-keys are far too clumsy for a long edit session.
So far the suggestions are helpful, but short of matching previous capabilities. (I’ll try and burn an Xubuntu dvd shortly,
but have some fire-prevention chores first}

I’m not a coder, but I imagine audacity is one of only a few programs where there is such deep zooming available
that use of the scrollbar is negated. (pixel editors?) Perhaps some documentation is needed detailing exactly which window-managers
can provide < and > , how to achieve that, and how to configure them to work correctly with audacity zoom feature.
Most people are in some form of gnome, kde, mate, xfce, lxde etc so the documentation would be a pretty short list,
probably under 20 window-managers.

I’d like the linux version to be better and easier to use than the windows version. and able to function precisely
across the majority of major linux environments. Maybe there are just too few people using these functions
to make it worth while?

The scrollbar’s < > buttons appear to be going out of fashion. I notice that Firefox stopped having them since using gtk3 in 2016.

If < and > are going out of fashion because other apps don’t need it,
then let’s hope the linux audacity coders will do what it takes to keep it in fashion
either internally, or as part of the linux installer dependencies.
Might require older gtk or wxwidgets or whatever collectively supplies
that functionality, but it would be nice to stay equal to, or superior to
windows versions, and older linux distro releases.
mi dos centavos

The irony is that I have those buttons, and I never use them. I would happily send my < > buttons to you if that were possible :smiley:

I made live dvd’s of current Xubuntu 20.04 and 18.04, When I installed audacity
in the booted live settings, neither had the < and >
When adding the .css file mentioned, they appeared, but clicking them barely nudges
the screen position, regardles of zoom amount. Something amiss.

On the bright side, I also burned a 2018 vintage iso of AVLinux, also xfce based, and audacity works properly
out of the box. It has wxWidgets 3.0.2, whereas distros I’ve tried that fail have
wxWidgets 3.0.4 or 3.0.5.
Hurray for the weekend, blended as it may seem with the times formerly known as the workweek.

Here is a puzzle. I realized the configuration I told you about was for gtk3, and it adds arrows. But then I read Audacity uses gtk2?

I tried configuring gtk2 as advised here (but using location ~/.config/gtk-2.0 for gtkrc).


But it has no effect, could be our Audacitys are compiled against gtk3?

Another possible work around is to use ‘,’ and ‘.’ (with shift for long) to step through track?


Some recent repository builds of Audacity are incorrectly built against gtk3.