Missing Option for Locating or Downloading FFmpeg

I have Audacity version 3.5.1 on my Windows 11 laptop. Windows 11 is up to date as of 06/29/2024. All was working well and then I lost the ability to use FFmpeg to convert from mp4 and m4a files to wav. I had FFmpeg version 5.0.0 as well. When I went into Edit, Preferences then Library… the options to either locate or download FFmpeg are missing. I have uninstalled and reinstalled both Audacity and FFmpeg but to no avail. Both of these programs appear in my C drive within the Programs folder. I’m at my wits end. Any suggestions would be greatly appreciated.

Did you download and run FFmpeg_5.0.0_for_Audacity_on_Windows_x86_64.exe?

Audacity does require it’s own version of FFmpeg.

That should install it to C:\Program Files\FFmpeg For Audacity and you should be good-to-go.

Does anything related to FFmpeg show-up under Libraries?

I wonder if something is wrong or “unusual” with your MP4 files.

You should be able to convert the files to WAV with Kabuu Audio Converter TAudioConverter or

Thanks for the reply. As stated, I downloaded the FFmpeg for Audacity and it downloaded as FFmpeg ver. 5.0.0. I ran the installer and it placed a folder labeled as FFmpeg for Audacity in my C:/program files. The Audacity ver. 3.5.1 Folder is in C:/Program files as well. The only thing that shows up in Library is the Lame mp3 export Library. I’ve tried moving FFmpeg to other locations but it seems no matter what I do I still cannot seem to get it to work again. Also, I have been using an online program “Wav Convert” for a week or so. It works well but I’m rather rural and the only Internet service available to me is T-Mobile home internet and the up and down speeds are nothing to brag about .

Greetings again. After our last communication I continued to have the problem with FFmpeg until I finally found the solution yesterday 07/12/2024.

Yesterday I uninstalled both Audacity 3.5.1 and FFmpeg 5.0.0. I then manually removed any lingering artifacts.

I did a fresh download and reinstall of both applications.

I opened Audacity, imported a mp4 file and attempted to save it as a wav. Once again it failed. Intense frustration.

I then began to look into the Edit Preferences section. There was no reference to FFmpeg in Library.

Just on a hunch I began looking into each of the additional sections under Import/Export and when I looked under Modules and located mod-ffmpeg it was listed as failed.

I then clicked the downward pointing V and several choices were displayed including “enabled”.

I chose “enabled”, clicked OK .

I don’t have a clue as to why it had been labeled as “failed” but by changing that value to enabled it completely solved my problems.

Just thought I would pass this along to you. I don’t know how to post this on the forum so that anyone who runs into this glitch can find it but maybe it will appear under an appropriate heading.