Misbehaving on Ventura

I updated to MacOS Ventura yesterday. Labeling no longer works properly.
I usually have the name of a classical composition saved from some track listing (cmd-c).
I add a label (cmd-b) and then paste the composition name into it (cmd-v). In Monterey, the mouse cursor was at the end of the pasted label, so I could just type in the movement name (for example). But in Ventura, I must click on the end of the pasted label. I can then type 1 character. The cursor then is removed from the label field, and I must click it again to type the rest of the label.
Audacity 3.2.1 for ARM

What I’m seeing with macOS 13, both Intel and ARM, is that shortcut keystrokes are not being captured by the label being edited, but instead trigger the action. For example, typing a space while editing a label causes Audacity to begin playing.

I’ve just upgraded my MacBook and iMac to Ventura, so I can’t test if this behaviour existed with Audacity 3.2.1 on macOS 12.

– Bill

Well, I tried this on my partner’s Macbook which is still running macOS 12.6. Running 3.2.1 on that Macbook there is no problem editing labels.

I noticed that on macOS 13, when I do command+B to open a label, the label track does not have the yellow focus border. But even after clicking in the label to get the focus border on the label track, editing is still a problem (it is hard to describe - sometimes keystrokes trigger actions, sometimes characters are added to the label). If I delete the label track the one remaining audio track does not get the yellow focus border.

Very strange.

– Bill

This makes it really hard to edit labels!
Please Fix!!!

It seems that after cmd-b, the label is created
but the window focus is lost.
That’s why the keys you think are going into the label are
instead interpreted as keystrokes for shortcuts etc.

Ventura also broke Malwarebytes, though a Malwarebytes beta has fixed it.

I tremble to think what will be the next Ventura BS we encounter.

Pre-Ventura I was at 12.6.0.
Someone reported that Malwarebytes was broken by 12.6.1.
So probably we have to revert to 12.6.0 for Audacity too.

Maybe I’ll try that.

That’s what I meant by the “yellow focus border”.
– Bill

The entire window loses focus: the window size buttons top left go grey.

A further observation: the problem arises if the label is created via the menu pick; cmd-b itself is not the culprit.
As you said: very strange!

Expecting more trouble with more apps, I looked into downgrading OSX … looks very messy.
A bit of irony here, I only intended to go to 12.6.1, but the upgrade was hijacked by Ventura.

Good observation. And it gets worse:

Open a new project and do Generate > Chirp.
While the Chirp dialog is on screen obviously the project window does not have focus.
Click the Generate button.
The project window briefly gets focus (window size buttons are active, generated track has yellow border), then loses focus
Switch to another application then back to Audacity - project window has focus
Delete the track using the “X” button in the track control panel - window loses focus

And on it goes.

So it appears the problem is deeper than label editing, and instead a general failure to maintain focus? And this has appeared with macOS 13 (lucky 13?)

– Bill

This behaviour of the window losing focus goes back to at least Audacity 3.0.0 when running on macOS 13.0.

Start 3.0.0
Start recording
Stop recording using the space bar

  • window widgets at upper left are grey, no yellow focus border.

– Bill

What a pain!

I’m tempted to give Ventura 13.1 beta a whirl…
surely that would solve everything…
oh I know, that would be a big mistake.
But if anyone wants to give it a go, three cheers!
Not me.
HOWEVER, I made a little “Keyboard Maestro” macro that makes cmd-b
do what it’s supposed to do. I bound it to cmd-b of course.
If anyone is interested,
save the attached 'kludge for labels.txt" as “kludge for labels.kmmacros”
and import into Keyboard Maestro.
kludge for labels.txt (6.35 KB)

Try this one. It just brings the front window to the front instead of switching in and out of Audacity.

Same procedure: change the extension to “kmmacros” and import into Keyboard Maestro.

– Bill
Add label at selection.txt (4.95 KB)

Thanks! Much better.
Amused by “Bring Front Window to Front”!

I changed “Audacity 321” to “Audacity”. Works great.
On editing an existing label in place, the focus is lost.
For that, right-click & Edit Label seems to work.

I’ve been happy with Ventura so far.

In addition to the labelling inconvenience Audacity 3.2.1 doesn’t honour ‘press and hold’ to produce characters with diacritics: repeats instead.

WIndows guy here and not familiar with diacritics. However, does the suggestion offered here help: https://discussions.apple.com/thread/8222758 ?

I just updated to Ventura 13.0.1.
No change with the problems typing into labels.
but at least the Keyboard Maestro macro works fine,
especially with the improvement offered by @billw58 .

However, Ventura also busted synchronization with Google Drive for Desktop.
If you remove these:
sudo rm ~/Library/Application\ Support/Google/DriveFS
sudo rm ~/Library/Application\ Support/Google/Drive

reboot and restart Google Drive,
it will be back working.

Not Audacity-specific, but probably some of you Ventura-sufferers use Drive so why not.

Brand new
Audacity 3.2.2 solves the conflicts with Ventura.
(So far)