Midi in note track gets out of sync

The out-of-sync issue I’m seeing is specific to midi/note tracks, I know how synclock works and all the clips in my project are exactly where I want them to be. It’s just the notes inside all clips on the note/midi track that keep getting misaligned.

I don’t know if there’s something wrong with my project, but the behavior I’m seeing is that:

  1. I import a midi track
  2. I drag the clip over where I want it to be
  3. I start aligning audio clips in other tracks with the midi visually
  4. At some point I look up, and the clip in the midi track is still in the same position, but the notes in the midi track have condensed left.

I’ve actually seen it condense itself a couple times when I hit “ctrl+z” which is the only clue I have so far, because as far as I know I haven’t been interacting with the midi track at all, but when I undo, suddenly something changes? I see a “velocity” slider for the midi track and I wondered if that was somehow getting misaligned? But each time I’ve checked velocity it’s still been at 0. I’ve tried changing velocity to see if that would help, but nothing happens visually when I adjust the velocity.

If velocity somehow only applies to the audio for a note track—I wouldn’t know if it’s being applied that way, I see there’s an ability to playback midi tracks but I haven’t followed the steps to figure it out so it’s just silent for me

I’ve tried importing an extra copy of the midi track and keeping it out of the way at the bottom where I definitely wouldn’t be interacting with it (It’s below some label tracks from the other audio, so even if sync-lock were on, which it’s not, it would be independent), but the copy also gets condensed so that’s no help.

If there’s somehow a hotkey that’s fighting with ctrl+z, I’d love to fix it, but I didn’t see anything that looked relevant in my preferences. I would love some help as to where I could even start with this. What am I missing?

So far the only workaround I’ve found is to re-import the midi.

This issue continues to happen consistently, and I’ve confirmed that it also happens when I hit the undo button rather than using a shortcut. I’m using audacity 3.5.1