Microsoft Sound Mapper input

Moderator note: This isn’t explicitly about recording from an HDMI input, so I started a new topic for you with a relevant title.

on older versions of audacity i could just select the soundmapper output dropdown from recording devices’s and it would record anything being played on my laptop…but havnt been able to make it work on these newer versions

The “Sound Mapper” simply selects the current Windows default. Presumably the default on your machine was “Stereo Mix”. If you are on Windows XP, try selecting “Stereo Mix” in the device toolbar. If you are on Vista or later, try the “WASAPI loopback” option as described in the manual: