Microphone volume slider is setting itself to 0 [SOLVED]

I’m Using Windows 7, Audacity 2.1.2, and used the .exe installer.

I can’t record because the Microphone volume slider is automatically setting itself to 0. I can move it to 1.0, the wait 3-15 seconds, and it moves back to zero. Like a “ghost”. I don’t know much about audacity, but have used it for my simple needs (making digital transfers of records) for years. Is this a virus? I have un-installed and re-installed already. Windows volume/sound us normal, it seems to just be on Audacity.

Any help is greatly appreciated!

Microphone volume resetting to zero is almost always a driver problem in your sound card. What sound device are you choosing in Audacity’s Device Toolbar?

There is some help with drivers here: http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers.

It “could” be a virus, but it never hurts to do a full anti-virus scan with your favourite anti-virus application.

It could also be an interaction with another application. Skype can do it, and voice tuning applications can do it.


Thank you for your response. It is still resetting to 0 if I use any of the 3 (MME, Windows Direct Sound, Windows WASAPI) sound devices available in the Device tool bar.

I Updated the driver on my computer which is “High Definition Audio Device” made by Microsoft.

I put Skype folder in the trash and emptied trash. I don’t think I have Voice Tuning applications.

I also ran my scheduled AVG Virus scan.

Slider is still resetting to 0 after a few seconds. Going to restart pc now, just in case that helps since I hopefully deleted (enough of) Skype.

That could be the problem, as described in the link I gave: http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers. Assuming you have a branded computer like Dell or Lenovo, you want the latest audio drivers intended for your computer model, obtained from the web site of the computer manufacturer. Audio drivers made by Microsoft are generic and not matched to your specific motherboard audio device.

If those were operational parts of Skype you’ve probably now wrecked it, and perhaps left parts of it running that are no longer properly installed. The correct approach to test if Skype was to blame for your problem would have been to exit the Skype application, then go to Windows Task Manager and shut down any other services or processes it may have.

As it is now, I would recommend reinstalling Skype (and then if you don’t want it, uninstall it using the Windows Control Panel).


Ok, I updated HP’s audio driver for my model and also re-installed Skype, and the uninstalled it using Task Manager.

The problem persists. Still sliding back to zero and no signal. I know the cord is good as I am using it with another computer.

So you don’t have Skype at all now? And you’ve tried the correct audio drivers from HP’s site?

How many audio input ports does this computer have? Just a microphone input? Or is it a desktop that has blue line-in as well as pink microphone inputs? Note that you won’t get the best quality recording LP’s into a microphone port.

Has this computer always had this problem, or has it only just started? if the problem only just started, and you can’t think of anything you changed on your computer to account for it, then you could try a Windows System Restore back to a point before the problem started. This might restore old generic audio drivers, and might partially (incorrectly) restore Skype. System Restore will tell you what applications and drivers will be deleted and which might be partially restored.


I do not have Skype anylonger, nor do I want it. If I search for it, there are still a couple “skypish” things that pop up, even though I uninstalled it using Control panel.

And I got the up to date audio drivers from HP for my computer.

I have used this computer (HP Probook 4530s) for some years for this same task, using audacity, with no problem before. The audio input I use is USB. My computer just has one 1/8" audio input jack, but I’m not using it at all. And no, I can’t think of anything that changed. At one point, I thought I found something online about a virus that does this to audacity, but I have not been able to find the site when I’ve looked recently.

I’ll try the Windows System Restore.

It’s good that you have updated motherboard audio drivers from HP, though they won’t be directly relevant to your problem now you have told us you are recording with a USB recording device. What device is that exactly (make and model number)? Is it a USB turntable, or a USB phono interface for a standard turntable?

You could also look in Device Manager for any yellow exclamation marks against this USB device or against “Universal Serial Bus controllers”. If so, use the right-click options for the offending device to update or uninstall drivers. If the device does not have special custom drivers, uninstalling the device and rebooting should make Windows attempt to reinstall the device.


The oldest System Restore Point it is giving me is from yesterday. This problem started a few months ago, so I don’t think it will help. Right?

Any other ideas?

Correct. But for future you could consider allocating more space to System Restore so that it can retain more restore points. Right-click on “Computer” from the Desktop or Start Menu, choose “Properties”, then in the System panel, click the link at the left-hand side for “System protection”.

See my previous post. What USB device are you using to record?


I’m using an Audio Technics At-LP120-USB. Turntable. It’s working fine with my friends computer/audacity currently also.

There are no special drivers for that device as far as I am aware. There is a small chance there is a hardware fault with the USB port you are using and you might try a different USB port.

Also what happens if you right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the LP120 then choose “Properties”. Then click the “Levels” tab. Does adjusting the input slider retain the level?


The slider setts itself to 0 regardless of what my mic input is set to.

As far as I can tell,my USB ports are functioning normally with other devices

I followed the above and it recorded (at 100 it was peaking like crazy) for a few seconds, and then it slid itself back to 0.

I fixed it! It was some form of malware I think. Malwarebytes got rid of it. Previously I’d only ran AVG antivirus as that’s all I had. Thank you for all your help! Very happy I can use audacity again!