Microphone is not recording


as the header states, I’m having some issues when I try to record sound using a microphone.

The microphone is a “Boya, BY-M1 lavalier microphone” it connects with a 3.5mm mini-jack.

Audacity version is 2.1.2. installed from the linux distro.

Operating system is Linux Mint 18.2 Cinnamon 64-bit.

When I go to sound setting - input I see, that Linux has connected the microphone, but in Audacity I am only able to record blank audio files.

In Audacity - Preferences I set the host to ALSA(only possibility). I have many different possibilities in playback - device, and recording - device. I tried to follow the instructions on the audacity website, which recommends default settings for ALSA. That did not work, so I tried many different combinations and I tried to connect microphone and speakers in different slots(I have input slots in front and back of the pc).

I have also tried to use some other free software, but also with no luck.

Please have in mind that I am not a Linux expert! The only reason I use Linux is because I find Windows monopoly repulsive.


Reboot your computer, then connect the “Boya, BY-M1 lavalier microphone”.
In a terminal window, enter:


Switch to the “Input devices” tab and look for the microphone. Can you find an input device that shows a response if you gently scratch the microphone gril with your finger? (never blow into a mic)

Hi Steve,

I rebooted as suggested and installed the “pavucontrol” and I see a “Front microphone(plugged in)” at the input tab. I do get a small constant response from the microphone, same as in the Linux - Sound settings - input menu.

That does not sound right. What normally happens with a microphone is that when there is no sound going into the microphone, the meter shows a low level signal that jitters around randomly (noise), and when you scratch the microphone grill, or speak into the mic, the meter should very noticeably leap up and down in response to the sound.

A constant level signal on the meter indicates that the mic is not working (check that it is plugged in correctly, in the correct socket.

Does your computer have separate sockets for microphone and headphones?
Is it a laptop of full size computer?

That was a bad explanation on my behalf. It is a constant jitter as you put it!

However, there is no significant response when I touch or speak into the microphone.

I am using a fullsize computer that I build myself. It has seperate sockets for microphone and headphones in the front and three sockets in the back(red, green and blue).

Are there any other microphones connected to (or built into) the computer (some webcams have built-in microphones).
(It sounds like you are looking at the meter for a different mic.)

No there is no other microphones or webcams installed at the moment. I just switched from the front socket to the back socket and the “input device” tab recognize that. It goes from “front microphone(plugged in)” to “rear microphone(plugged in)”.

I just tested the microphone on another computer and you are absolutely right, the microphone is defekt for sure.

Thank you for your time and effort I really appreciate it!!!

the microphone is defekt for sure.

What does the plug on the microphone cable look like?

Is it a ring-tip-sleeve like this? Two black bands?

There are two ways to connect a microphone. The computer method has two black bands, but my Olympus recorders take a microphone with only Tip and Sleeve, one black band. You can’t easily cross them.


Ooop. I see the microphone has a battery compartment in the cable. You did put the battery in, right? It takes an LR44. I generally use a Silver 357 for better performance.

You also have to turn it on.