Microphone error

I work with a MacBook Air and a Yeti Blue microphone. Every time I make a recording I get error ‘9986’. but sometimes also error ‘9997’ I have already done audio scanning and also allowed the microphone in privacy. I do not get it at all. (tried another microphone) I get the same errors. Van somebody help me please?

How did you connect them? The Yeti has a Mini USB-B on the bottom. My older Air has a USB-A on the right side. Adapter cables between those two are as common as dirt. The newer Air has two Thunderbolt/USB-4 connections. Has anything ever worked connected to those two? Or do you have an older Air.


Does the light on the front of the Yeti come on? It’s supposed to be on steady during normal operation and flashing during Mute.


hi, I have a MacBook Air (2020) running Sonoma and using an Yeti Blue microphone which works fine - checkout the help pages Error codes - Audacity Support and also verify the transport options like recording and monitoring - make also sure that your laptop is powered and not running on battery - good luck

Yes it does. Looks normal

Hi Thanks for the tips. What kind off adapter do you use? Maybe mine is not good enough? And the laptop was not connected (so it did run on battery) Maybe thats the problem.

Well that’s what I was thinking about too. I have a small adapter that I place in between. (I have the newer MacBook) I have also tried another one. but same error (it was a cheap adapter) But as soon as I connect my microphone I get a red light so I assumed it worked.

I have been using different USB C Hub adapters and they all worked fine.

Strange thing is that GarageBand gives no errors… So then it must be a thing with Audacity. But what?

have you checked this article yet?

Oh thank you!! i’ll checked and i have one question; In the solution to repair they say: Search your desktop for ‘audio Midi Setup’… Do you know what they mean where to search? Can’t find it… help

check out this video - or hit Command-Space bar to open the Spotlight window

Great! Learned something new again. Thank you. I made some movements with the mic and now i think its the connection of the cable. then you see the red light also on and off… So i have to buy a new one to find out. Thank you for your help so far!

just to be sure: a red flashing light on your mic means it is muted and you need to push the button to unmute it :wink:

:wink: i know haha. Ohhh problem solved :wink:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.