Metronome Ticks Removal

Hey. Please see the screenshot below. I was recording a part while monitoring a metronome in my headphones. Either I was too close to the mic or the volume of the metronome was too high. You can see the four ticks in the screenshot. I highlighted the area of the track above it as a clue. You see one tick in the mid altitude, that must be the downbeat, followed by three ticks in the lower altitude. What can I do about this?
metronome tick.jpg

There is one mind-bendingly common problem when you’re overdubbing and that’s to have the backing track show up in your performance. It can be bad settings. Leaky headphones need not apply.

Make sure your recording device under the little microphone symbol is a real “thing” such as one of the connections from the built-in soundcard or the data name of your USB microphone. Something you can reach out and touch. What you don’t want in that setting is a software redirection program like you would use to record internet music or shows. You can’t reach out and touch that. That’s the kind of thing that gets left by accident and routes the metronome back to you along with your voice or performance.

We should wait for a better editor to sort how to get rid of metronome clicks once you have them. Are the clicks at the same time as parts of the show? Are they over background silence? Audacity has a very hard time splitting a mixed performance into individual voices, instruments, or sounds.


These ticks are mostly buried, but show up off and on throughout. I thought I might be able to filter them out, but I don’t know how.

Are you on Audacity 2.4.2? If you haven’t already, File > Save Project > Save Lossless Copy under a unique filename.

Set up for another recording as a test and this time leave your headphones off and under a pillow or blanket. It doesn’t matter what the performance is; we’re trying to see if the leakage goes away. Leave some silent time. You can’t unplug them because that will change the computer configuration.

Still there?

What is the microphone entry say in this line at the top of the Audacity menu panel.

Screen Shot 2020-09-21 at 12.25.17 AM.png

My system info used to be in my sig. Why is it not showing. I’m not recording now. These recordings were made on the fly and I’m now only editing. So I’m not interested in anything but correcting these tracks. If I can’t filter these clicks out then I’ll shelve these tracks and wait until I can redo the recordings.

A search tells me that sigs are disabled now. I only knew what my system was by my sig!

Looks OK to me


I had complete info about my system in my sig. I understand that it’s disabled due to abuse. I’ll see if I can expand that info later. Any ideas on what can be done with these clicks in the editor? If there’s no hope, I’ll leave it and go on to something else.

OK. I’ll tell you what I need to know. I need to know how to read the information in the spectrogram. What does it mean that one tick (the downbeat) is located midway in the altitude of the track? And what does it mean for the following three ticks to be located close to the horizon of the track? Does that represent amplitude or pitch?

I’m taking a look at this page:

Try running this command in a Terminal window:

uname -a

(The “a” option means “all”)

I don’t know what you mean. If you are referring to a track in your Audacity project, then a screenshot may be helpful.

Right. The screenshot is in the OP. Is there a way to filter those four ticks out?

And what does it mean for the following three ticks to be located close to the horizon of the track? Does that represent amplitude or pitch?

Spectrogram View is frequency (pitch) up and down, duration left to right, and loudness is colour.

You can drag the timeline taller and the frequencies listed along the left will get more accurate and easier to see.

Screen Shot 2020-09-21 at 10.03.04.png

Is there a way to filter those four ticks out?



Then my other option is to go through every millimetre of the track and reduce the volume of these click when they are apparent. Is that easier to do in waveform or in specto?

Then my other option is to go through every milometer of the track and reduce the volume of these click when they are apparent.

I thought you were going to fix the recorder and shoot it again.

I’ll shelve these tracks and wait until I can redo the recordings.


Ok, here is an option. Not perfect but maybe works for you:
1- Enlarge your track as much as you can:
01-Enlarge your track.png
2- In the Spectral view, place your mouse over the frequency scale and using Ctrl+ your mouse wheel max the frequency scale so you can see exactly the freq where is the metronome clicking:
3- Go to Effect/Filter Curve… and enlarge the effect window. Decrease the +db slider at the right of the effect and increase the -db slider. I recommend to check the Linear Frequency Scale option so can be more precise for the next step:
4- Make a notch cutting the frequency of the click (I can see in your image that the accent is around the 4K and the others around 2K but you can only be sure after the freq zoom):
04-Make A Notch.png
This method is not elegant, but maybe can works for you. If your recording doesn’t have nothing important on those freqs, you can select all of your file and apply. Or just select the portion where it is more noticeable an apply there.

Good luck!

I forgot to post how mi example sound file looks like after that:
05-After applying.png

exactly the freq where is the metronome clicking:

Yes, but. Metronome clicks are splattery. See in the posted spectrogram, the clicks are tall? They cover multiple frequencies. That’s why this is such a pain-in-the-neck problem.

This is a lot like telling someone to separate out one musical instrument from the others. Or “remove this drum” from a mixed song.

Another right-out-there solution is, if possible, collect one or two “clean” clicks and paste them onto their own timeline. Now paste them again and again until you have about a second or two of clicks, one after the other. Drag-select the whole pile and use it as Effect > Noise Reduction > Profile.

Then run Noise Reduction on the performance and see what happens.

If you really did get this interference from headphone leakage neither of these is going to work because the click tones are going to shift as you move.

I’d go with the Record It Again option—after you fix it so it doesn’t click any more.


Well, I can record it again in a couple of months. I just don’t have the instrument with me now. I might go with the millimetre by millimetre approach if I can’t wait. I appreciate the detailed low-down on this, but I still have not managed to do the last EQ project that I posted in these forums. I’m afraid y’all are not going to take me seriously any more. Thing is, I have to do all of this bulk editing, then go through and detail all of the 50 some projects, then go back and try these very detailed edits. And all of this is in my spare time, only a few hours every week. So, that could be next year that I can do these very detailed edits. I’m going to have to switch gears then and concentrate on learning all of this stuff. Maybe I should wait until then to be pitching my problems around here. I just feel like I wasted your time, because it’s all kind of over my head at this stage.

You’re not posting problems like “how do I make my sound louder.” You’re posting brain surgery problems and some problems have no fix.


I hope I’m keeping you entertained. :mrgreen:

Thanks everybody. I thought it might be simple. I’ll do it the hard way, millimetre by millimetre. Besides, my recordings are so poor that I can’t afford to filter those frequencies. I’ve tried noise reductions before and gotten very bad results. You lose all the brilliance. And I’ve got very little brilliance to lose.