Memory problem?

I create a new file that is only one hour long, it takes a few minutes to save.
I record 24 hours of audio in one track. It can take as much as 20 minutes to save it. I accept this.

If I edit the 24 hour track down to 1 hour and save it under a new name, it still takes up to 20 minutes to save.
If I open the saved 1 hour file, make a minor change and save it to a new name, it still can take up to 20 minutes to save.

Is there any way to get Audacity to forget that the file used to be 24 hours long?

Audacity UNDO is done by remembering the whole show, multiple times.

I don’t know any way around that.


You could be accidentally exporting (saving) the full 24 hours, rather than just an hour.

or “Ctrl”+“F” will zoom-out to show the entire audio file you’re working on.
'Export audio' saves everything, not just the selected bit.gif

I want both the 24 hour recording and the 1 hour is a test.
My point is that Audacity seems to believe that one hour of audio from the 24 has the same amount of saving space. This applies also to when I totally close everything then open the 1 hour file. Saving the file again takes 20 minutes yet a new 1 hour file takes only minutes to save.

Unfortunately, I cannot seem to find out what the file size is for any of these.

I cannot seem to find out what the file size is for any of these.

And that’s the Twilight Zone moment. Doesn’t Windows want to tell you the file INFO?


Here’s a guess.

You edited 24 hours down to 1.

You deleted many sections. You did that with the Cut command, not delete, and you had Enable Cut Lines checked in Tracks Behaviors preferences.

This leaves red lines in the track, which you can right-click later to delete the audio completely, but if you don’t, it’s all remembered so that you can expand it again later.

That’s one way an apparent one hour of track might really contain much more. But I think it’s unlikely you did this unawares though. You would have had to change an obscure preference and then not noticed all the red lines.