mda stereo, pitchproof and kerovee problems in 2.1

Great to see real time effects, but I’m having to also use a portable version of 2.0.6 to get the above to work.

I’m on windows 7

In 2.1 kerovee and Aegean Pitchproof break up and are unlistenable to
and their different settings can’t be assessed in realtime and their is no preview button to as before. Therefore I can’t use either.

mda stereo sliders don’t work - only the default.

There’s a couple of others similar can’t remember which offhand I’ll have to double check later.

Ah yes! uhbik A, D, F etc only work if playback is stopped and then restarted before changing to another default setting.

For everything else that does work:
A big drawback in ease of operation is he GUI Audacity has employed to load the effects. Many of the effects dropdown alternative settings are now buried in a submenu which makes it slower to switch defaults in real time. Also the menu button should be at the top of the dialog because the effect dropdown menu has to often be scrolled down on a smaller screen

I have Kerovee to hand. Are you saying the same settings distort in 2.1.0 and not 2.0.6?

It works for me. Press Play in the main Audacity window or the Play button in Kerovee then move the knobs on the effect. I hear the sound change.

I can reproduce that, so I’ll report it.

No Factory Presets other than defaults are listed in Audacity’s menu until I add them. But perhaps it is a trial limitation? Do you see all the Factory Presets listed in Audacity’s menu?

Even if I add a Factory Preset (using the effect’s Save button), only Defaults moves the knobs, either stopped or playing,

When you press “Patches” and select different factory presets is that supposed to change what you hear in real time? It doesn’t for me, but again I only have the trial version.

I would save a User Preset and use those, which appear to work.

OK, I can see that. But it was probably felt it would take too much space to have all the User, Factory and Export/Import controls embedded in the effect.

What screen resolution do you have?


I tried kerovee on the latest nightly build and an error report screen appeared, I
wasn’t on the internet so pressed cancel and audacity shut down.

I only have a few minutes of internet access at a cafe to post at the moment so my last post could have been clearer. I deleted the nighly build.

I retried kerovee on 2.1 and this time the sound didn’t distort but the presets would not change. This is what I am referring to, the various knobs etc can be adjusted, but I usually work with effects by swapping around their presets before fine tuning with the various knobs or sliders. All the prests work fine in 2.0.6

2.1’s interface “steals” the dropdown preset menu from many effects. It only requires one visible dedicated button to restore what has been “stolen” I don’t see how that would clutter anything. Reaper and Samplitude for instance don’t do this. I don’t use either of them except for realtime effects.

My screen resolution is 800 x 600 on a ten inch notebook with a high dpi. I can’t comfortably read most audio interfaces at other resolutions even with glasses. Some other daws in aprticular are a nightmare for this. .

Gotta go

Forgot to say…uhbik swaps from preset to preset fine on Reaper.
It’s not just ukbik that doesn’t switch in realtime on audacity but I’ll have to take time out to go through what does and doesn’t again.

Did you add the effect using Effect > More… ? That will probably have caused that one-time crash. We still have to make that safe.

Are you using a mono track? I can reproduce that with a mono track, but not with stereo.

Please give some screenshot examples of what’s been stolen that you see in Reaper or Samplitude but not in Audacity. I don’t have Reaper or Samplitude but the Kerovee interface has no presets menu in Wavosaur - its interface looks like it does in Audacity and the presets are inside a Wavosaur dialogue.

Audacity doesn’t support 800600 any longer, the minimum is 1024768. If and when we support mobile devices, no doubt resolutions for those devices will be looked at.

Do you see Factory Presets listed in Audacity’s Manage menu? I don’t so I can’t switch that way. I can switch factory Presets in Audacity using the “Patches” menu in Uhbik-A, but I agree that requires restarting playback in Audacity to hear the changed preset. Is the Patches menu how you are switching presets in Reaper?


Regarding the preset menu - old audacity does it just right - immediate access - as in Reaper and samplitude. Any older Audacity preset dropdown is the generic screenshot.

I don’t know why you are complicating this Gale? Immediate one click access to the preset menu is the issue rather than having an extra click each time to go into the new Audacity submenu.

Some vsts retain their own dropdowns within their gui’s whilst others only display via the preset menu system employed by the host daw.
If you doubleclick click on Uhbik as well as being able to scroll the presets with the arrows you get dropdown menu - but that’s not the issue here. Uhbik swaps presets in realtime without having to stop and then play again. I’m finding the similar failings in Audacity on some soundtoys vsts and also realtime parametric eqs - Fab filter pro and reaeq - sometimes the sound changes as the eq profile is dragged, sometimes it doesn’t.

I’m using an activex host and waves vsts are problematic with having to stop and restart play in Audacity

I just don’t have time now for all the specifics I’m travelling and camping.

Ambience is another vst that readily distorts in Audacity but not in Reaper etc.

There’s also an issue of vanishing individual presets I’ve had this korg mde-x, ambience and uhbik_P - difficult to reproduce becasue it only happens randomly.

Normally If Korg mde-x is unclosed it retains the last used preset instead of having to scroll down the very very very long list again…but not in the new audacity I have to scroll down afresh each time

I just don’t think this version of reaper has been tested properly. I’d call it an alpha or beta version where realtime effects are concerned.

also the play stop button is also redundant when all that is needed is to use the spacebar - makes life a lot easier on reaper and samplitude, but having the play/stop button brings in isues of focus.

I’m b

I already passed your comment on to the developer who designed real-time preview.

If you want more traction, please sign up to the audacity-devel list and make your suggestions there.

If it helps, (on Windows) you can access the Factory Presets from anywhere in a real-time preview effect by typing M F.


SPACE only works to play/stop in the effect when its Play/Stop button is selected (although that button is selected after you click on it).

Visually impaired users expect to TAB through buttons in a dialogue to select a button, then use SPACE to activate that selected button. That is the main reason the standard Transport shortcuts don’t work in real-time preview.


Thanks Gale the M F shortcut is very handy, is there also a shortcut for User Presets?

Talking of which - I just noticed with concern that my numerous User Presets in Toneboosters EQ saved whilst using Audacity 2.1.0 (installer) are listed but no longer work in 2.1.1. They don’t load graphically or change the audio. Presets made since installing 2.1.1 do work.

I’m on Windows 7 with 2.1.1. installer.

As far at ToneBoosters is concerned, saving presets is “crippled” on the free versions of their VST plugins …

[ Bold emphasis is mine ]

After pressing M, access any available item in the Manage menu by typing the first letter of its menu item.

So, type M U for user presets or M I for Import Presets, and so on.

Thanks for the report. I did not know this was a problem myself.

The parameters for saved presets are stored in the “pluginsettings.cfg” file in Audacity’s folder for application data. Where the plugin saves presets in a “chunk”, each preset has a reference to that chunk saved in pluginsettings.cfg, as before. So presets saved in Audacity 2.1.0 by such a plugin will still work in 2.1.1 and later, and settings saved in 2.1.1 and later will still work in 2.1.0.

Where the plugin does not use a chunk for presets we store the parameters as plain text in pluginsettings.cfg. The syntax used to store parameters in plain text changed in 2.1.1. So presets saved in 2.1.0 by plugins that don’t store presets in a chunk will not work in 2.1.1 and later (and vice-versa).

As an example, this is what the stored 2.1.0 preset looks like in pluginsettings.cfg if in Kjaerhus “Classic Chorus” we set all controls to maximum, except for the fourth control “Depth” which we set to 52%:


Here is how 2.1.1 stores the same parameters, giving each parameter a name and storing the value with greater accuracy:

Parameters=Depth="0.519999980927" Fine="1.000000000000" Level="1.000000000000" Mix="1.000000000000" Range="1.000000000000" Rate="1.000000000000" Spread="1.000000000000"

So I’m afraid without saving a preset in 2.1.1 or later to find the control names, then inserting these names into the values of the 2.1.0 preset (taking into account the changed order) you can’t easily use presets saved in 2.1.0 in current Audacity.

FWIW, you can use the old six digit values when changing the syntax to that for 2.1.1 and later. And you can read what the old settings were (as 0 to 1 values), adjust the plugin controls to match and save as a new preset.

I’ll raise this problem after 2.1.2 has been released but I can’t guarantee we will want to go back to the old syntax.


Thanks for further shortcut info.

Here’s what I see in the plugins cfg for one Tb-EQ User Saved Preset

[pluginsettings/base64\:RWZmZWN0X1ZTVF9Ub25lQm9vc3RlcnNfVEJfRXF1YWxpemVyX3Yz/private/UserPresets/Song\ TB-Eq\ -\ CarStero01]

I think in the circumstances the easiest option for me could be to use a 2.1.0 or earlier portable version to apply a preset I want in the short term and take screenshots of each preset and then visually match in 2.1.1 + for the long term.

Yes, that is the old plain text syntax.

Yes that might be easiest if you don’t mind having 2.1.0 and the current version.

If you run 2.1.0 and 2.1.1 from different folders, this will give you two entries in the Effect menu for any plugins that are in both Audacity “Plug-Ins” folders. If that is very annoying it should be OK to put a renamed Audacity 2.1.0 executable in the 2.1.1 installation folder then run one executable or the other from there.

When you install 2.1.2 (when it’s released), it uses different wx30.DLL’s. The old wx28.DLL’s don’t get cleaned out by the 2.1.2 installer, but the 2.1.3 installer will do that clean up. So at that point (if you were to run 2.1.0 from the 2.1.3 installation folder) you would need to bring in the old wx28.DLL’s that 2.1.0 needs.


Thanks for the tips and upcoming 2.1.3 warning Gale.

Not wanting any double entries I opted for the renamed exe in the 2.1.1 folder. That worked fine.

I’ll copy in the old wx dll’s in a 2.1.3 future.

(edited because I wrote double twice :wink: )