MBox 2 | Linux | Play audio is ok. | Record is not ok. | Error -9997 Invalid sample rate

I couldn’t find the answer to the following issue in the following posts:

https://forum.audacityteam.org/t/mbox2-and-audacity-on-linux/32165/1
https://manual.audacityteam.org/man/error_opening_sound_device.html#Check_Audacity_Settings
https://manual.audacityteam.org/man/tutorial_selecting_your_recording_device.html

Here is the troubleshoot:

I plug Digidesign MBox 2 via USB into the computer and without setting anything sound runs perfectly OK.

I run alsamixer in terminal and I can see:
Card: PulseAudio
Chip: PulseAudio
I press F6: Select sound card, and the default setting is already selected.
Esc for exit.

I open Audacity, and open a mp3 file: File > Import > Audio
I can see the Rate of that track has been assigned to 44100 Hz
Edit > Preferences > Devices:

  • Under Interface, Host: ALSA (no other option to choose from the menu)
  • Under Playback: Device: default
  • Under Recording: Device Mbox2: USB Audio (hw:1,0) and Channels: 1 (Mono)

I play the track and it sounds OK.

I add a new track: Tracks > Add New > Mono track.
I can see the Rate of that track has been assigned to 44100 Hz
I point into the field of the new track, and hit the record button
There is this error:
Error opening recording device Error code: -9997 Invalid sample rate
I don’t understand why recording is not working.

Linux Kernel version: 5.7.9 (16 July 2020)
Many thanks for your help

Try setting both Recording and Playback in the Device Toolbar to either “default” or “Pulse” (“Pulse” is the default on virtually all mainstream Linux distros), then use “Pulse Audio Volume Control” (“pavucontrol” - may be called “Audio Mixer” or similar) to select the MBox as the recording device.

Note that Audacity must either be in recording mode, or monitoring, to appear in the Recording tab of Pulse Audio Volume Control:

  1. Launch Audacity
  2. Select “default” / “Pulse” in the Device Toolbar
  3. Click the Recording meter to start monitoring
  4. Open “Pulse Audio Volume Control” and switch to the “Recording” tab
  5. Select the MBox as the recording device.