Maya44 usb card 4 ch recording

I have the MAYA44 usb card,which operate OK for 4 ch recording with Windows XP.
Recently I switch to Windows 7 ,32 bit . Now I can record only 2 ch !
I downloaded the latest version of Audacity 2.05 ,does not help.
Please advise.

I would expect ESI devices to be able to record more than two simultaneous channels, as per Missing features - Audacity Support .

Which driver if any did you use on Windows XP from this list: ? If one of those drivers worked in Audacity under XP then those drivers must also enable EWDM support. In that case you could try any of the Windows 7 32-bit drivers from that list.

Choose the correct input device in Device Toolbar . You don’t want to choose a device that says inputs 1 and 2 or inputs 3 and 4 - choose a “Multi” device or one that does not mention inputs. Try Windows DirectSound host in Device Toolbar. If you are recording computer playback, you can try the Windows WASAPI host.

If you compile Audacity with ASIO support then you can use the ASIO low latency support in the drivers.


Thank you Gale.

I have indeed selected the Maya44 4ch as the input device in the Device Toolbar, but could only get the Mono(1) and Stereo(2) options, without the option to records all 4 channels simultaneous.
Even on the Windows Control Panel → Sound window, while I can select the Maya 4 channels device, I only see the different options for 2-channels recordings (different frequencies, etc.) in the combo box, without the options to records in 4 channels.
Tried selecting all available device drivers, but to no avail. I have re-installed the driver from the Maya CD, but to problem remains.

Do you have any idea how to fix this?

Please post the information from Help > Audio Device Info… top right of the Audacity menu.

Try “Windows DirectSound” Host in Device Toolbar, and in Windows “Sound”, uncheck both “Exclusive Mode” boxes. Then choose Transport > Rescan Audio Devices in Audacity.

Does that mean you tried the various Windows 7 drivers on ? I think you should do so if not. You could even try driver version 2.8.5 (despite it is for Vista rather than Windows 7), or if that does not help, 2.8.40.

A number of devices that provided multi-channel recording with Audacity on Windows XP no longer do so on Vista and later. I had assumed this was not a problem with ESI devices, but perhaps it is.

There are some other things you can try. Right-click over the Audacity application, choose Properties, then click the “Compatibility” tab. Try compatibility modes for earlier versions of Windows. Try those modes with other drivers from .

Try 2.0.4 ( ) which has Windows WDM-KS support, but be aware there is a chance it may freeze or crash your computer. If Audacity launches, try the Windows WDM-KS host in Device Toolbar.

If none of that works, then you would have to compile Audacity with ASIO support. :frowning: