massive problems recording in audacity 2.1.2 usind EMU E-DSP

Hi there,

I have massive problems in recording digital audio signals from external source. I am using E-MU E DSP soundcard 0404 Patch Mix DSP version 2.10.00 on Windows 7 and the latest version of audacity 2.1.2

When I want to record for example from internet radio or Audio-CD ( shown as wave 1/2 in the E-MU DSP), there is an input signal in the Mixer AND in Audacity, I can hear the audio and recording in audacity is no problem.

Since however when I want to record external digital audio (shown as S/PDIF in the E-MU DSP mixer /PCI, I also do have an input signal in the Mixer and can hear the audio, but I cannot record it in audacity, there is no input signal at all. I tried many variations of settings but i cannot find the “fault”.

Pleas help and thanx

Hi Connie, When you posted to our feedback address and we asked you to post here, we requested that you restart Audacity then attach the information from Help > Audio Device Info… top right of Audacity. Can you please do that? Please see here for how to attach files: This will let us know what inputs Audacity sees.

I understand that E-DSP is only a chipset shared by different EMU models, so please give us your exact EMU sound card model number. This is important in case we have to try to locate the sound card manual online. Have you looked at that manual yourself?


Dear Gale Andrews,
I am very sorry but although I studied your “how to attach files” I did not succeed to do so. How exactly do I have to attach or what do I have to attach? I mean when I open the “Help” button I only see the version-number or Audacity. It is the 2.1.2 Version, but its clear this don´t help for looking into what audacity sees. Maybe, please, you can explain me a bit more. What exactly do I have to attach? Sorry, I dont understand.

The EMU DSP Soundcard is 0404 (in the manual it says something like: PN: 02EM 880306001, but this might be just a productnumber). PatchMIx DSP Version 2.10.00. EMU 0404 Firmware Version 1.0, Driver Version File Version, Build Data: Apr. 29 2008,

Hope this helped a bit

thanx for your support
cheers Connie

Dear Gale,

Maybe you mean this: (?)

Programmversion: Jan 9 2016

Commit Id: 53b8fd5

The EMU Card Model Number is: EM 8850 ( PC 12894 - REV A)

If you obtained Audacity from and you click where you clicked on Help, a menu will drop down that contains “About Audacity…” at the bottom. “Audio Device Info…” is in that same menu, three items above “About Audacity…”.

When you have Audio Device Info open, click OK, and then in the window that appears, click Save. Then you can attach the saved file as I already described (click “Upload attachment” underneath where you write your reply).

Or when you have Audio Device Info open, right-click in it and choose “Select All”, then right-click in it again and choose “Copy”. Then paste into your reply.


log.txt (1.48 KB)
Hi Gale
finally - fool as i am, I understood and found what you need. See the attachements please. There are two files ( the log.txt - which means in german the “protokoll” and the audacity.cfg renamed audacity.txt.

Hope for now you can work with these datas and I did it right.

As I wrote before the EMU DSP Card Model Number is EM 8850 (theres also another one: PC 12894 - REV A)

Thanx for your patience and help

audacity.txt (3.88 KB)

log.txt (1.48 KB)
audacity.txt (3.88 KB)
Hi, as I´m not sure wether you received the attachements (I cannot see them in the send-report), here I send them again.

Hi Gale,
I have another remark: If I looked into the Audacity.cfg, it says beta version 1.3.12 and so on. But this is from older times. I of course am using the version 2.1.2
Also I want to tell you I am working with windows 7 prof 32 bit german, using Intel I 5 processor, 4 GB RAM, and the Soundcard is EMU DSP Card Model Number is EM 8850 (theres also another one: PC 12894 - REV A), it is a PCI Extension Card.

Thank you

How many EMU sound cards do you have? To clarify the issue you could attach a DxDiag Report (click the link in blue text to see how).

You have not attached or pasted the Audio Device Info requested. There is no guarantee we could help you even if you do provide that information. The best thing is to read the manual for how to use the sound card patchbay and remember that you have to choose the correct recording device in Audacity’s Device Toolbar (click the blue text to read more).

So if you have connected an external input to S/PDIF of the sound card, try choosing the S/PDIF input in Device Toolbar. What exactly is the external input you are trying to record?


Actually I have only one EMU Soundcard. I attached the DXDIAG-files for you - hope this time its right. Also the Audio Device incl. driver info.
Of course I know there´s no guarantee, but hopefully you can help - because everything worked perfectly in my older PC (Mainboard crashed).
Or is it the mainboard itself? It is now a a GIGABYTE Technology GA-H97-HD3. (But this is not the point, I only mention it for your information).

I read the EMU manual a hundred times, but I cannot find the fault (or any hidden checkmark).

In the Audacity´s recording device toolbar there is no choice for S/PDIF. I can only choose between MME, Windows Direct sound, and WASAPI. And only wasapi works (LIvestream recording is workimg well, a have a signal and sound in the Audacity - but still no S/PDIF, although I have a signal in the EMU and can hear it also)
The external input is Audio from a DAT-Recorder.

That box is the “Audio Host” box. Look one box to right of “Audio Host” at the “Recording Device” box and try choosing S/PDIF there. Or, choose the exact same input that worked on your older PC. You have still not posted Audacity’s Audio Device Info, so we cannot suggest what recording device to choose.

Have you been to Windows Sound, Recording tab and made sure the S/PDIF input is enabled there? If it is not enabled there, Audacity won’t see it nor will any other recording applications.

If the problem persists you could try installing the V1.82 Package driver and the V2.1 Digital audio system driver from I don’t know if those are exactly the correct drivers for the model 8850 of EMU 1404, but they are the closest I can find. According to, the Device and Vendor ID’s in your DxDiag report point to a Creative Audigy card, which makes no sense to me.

Or if you have a drivers CD for the card that claims to support Windows Vista or later, reinstall the drivers on that CD.

If you need help using your sound card or patch mix, it is best to search for audio forums online
where you can see respondents to topics are using your card or patch mix.


recording1.JPG (11.1 KB)
Hope due to my not perfect english this time these are the right attachements. (Becaus the audio device info is namend in german “Unterstützungsdaten erzeugen/Fehlerbericht”, which means a report of faults. Anyway, in the recording device box there is no possibility at all to choose S/PDIF. Even if I choose the same input as in the old PC there is no other choice, sorry. Also in the Windows Sound tab register there is no choice of S/PDIF.
Thanks for the driver suggestions. I will download and install them, but I will first wait and see what you suggest after you have received these attachements. Thanx for your patience and help


Dear Gale
I succeeded, now it works very well as it should!!! What was wrong? I disabled the internal onboard sound-device in the BIOS Since then everything is fine. So, as I presumed, somehow the internal soundsystem blocked any external S/PDIF in the EMU DSP whatsoever, and Audacity now recognizes all the signals. I thank you very very much for your help and patience and wish you good times. With best wishes from Berlin
Connie :laughing:

It is called “Tonegeräteinfo” as you can see from your screenshot, and also called that in the Help menu.

Thanks for telling us how you solved it. Was it necessary to disable the built-in sound card on the older computer?


No this is what was confusing. So thanx again.

It could be that installing the suggested drivers for the EMU might have avoided the need to disable the built-in device.

I assume it should not be strictly necessary to disable the built-in sound device just because you have a PCI card. Are the EMU outputs and inputs additional physical ports on the computer, and the motherboard audio ports still exist?

But I would say if you don’t need the built-in audio device, leave it disabled and don’t change any drivers. :wink:


Yes they are physical in/outports. But anyway. I for now will leave it as it is. I dont need the onboard card so i am happy it works now as it shiuld. Thanx again Connie.

Dear Gale,
since we successfully solved this old problem, I have another one: When I load a project and I want to record another track, the already recorded first track records again in the second track (to the stuff I want to record). So how can I just listen to the already recorded track and record a new one without recording the first track again into the second one? Did I forget to choose any checkbox to disable? (I must say that I de-installed the EMU DSP Soundcard because of some problems and I am using the onboard Realtek Soundcard for the moment just for testing-reasons before I buy another new-one. It seems to me that the stuff that I playback/what I hear is reorded again, but I unfortunatelly cannot find any settings in the windows sound to change these settings). Or maybe I should just change some settings in Audacity?
Thanx for your answer and help


Wear headphones and choose the correct input you are connecting the microphone to in Audacity’s Device Toolbar. If you don’t see the correct input, show and enable it in Windows Sound then restart Audacity.

If you need more help please tell us the make and model number of the microphone or headset you are using and how that equipment connects to the computer.