Massive distortion when recording on new laptop [SOLVED]

I’ve been using Audacity, recording from a USB turntable to my laptop, for many years on a really basic old Panasonic with Windows 7 with no problems other than what sounds like the occasional skip in tracks where I think the processor is too slow to cope!

I have just upgraded and bought a Lenovo Ideapad 5 with a Ryzen 7 4500 processor - but I can’t record anything without very loud distortion. Basically, it’s unlistenable! The bars give no indication of a problem as they are showing only the usual ‘blue’ waves and they fit well within the recording window. I am running Audacity 3.0.3 on the new laptop (I had the same problem on 3.0.2) and the settings are identical to those on the older version (that continues to run perfectly except for the skipping effect).

I have tried changing both the stylus and the USB cable but it’s still the same result. Whilst I’m recording via the USB input option on Audacity, I have also tested the laptop’s inbuilt (Realtek) microphone input but that records perfectly with no distortion.

It seems that the only other people posting on distortion are suffering from red waves - which is not my problem. I’ve uninstalled and reinstalled Audacity several times but to no avail. I’ve exported the tracks on to my usual flash-drive and iPod to see if it was just a laptop playback issue but the distortion exports through too.

My IT skills are somewhat rudimentary so if anyone can offer any advice in basic English I’d be eternally grateful! Many thanks,

Nige

I’ve uninstalled and reinstalled Audacity several times

Newer Audacity versions have a setting where you can tell it to also reset preferences and settings. Did you do that? An Audacity install retains preferences and settings from the previous version so to make upgrading easier. The problem comes when occasionally, preferences or settings are causing problems. Then you don’t want them to hang around.

Drag-select 8 to 10 seconds of distorted sound. File > Export > Export Selected Audio > WAV > Microsoft 16bit.

Post it here. Scroll down from a forum text window > Attachments > Add Files.

Koz


Hi, thanks for the quick reply, appreciated. No, I didn’t do a reset of settings and preferences so I’ve uninstalled, reinstalled and done the rest this time. The distortion is still there so I’ve attached a sample (I think!) as suggested. Thanks

It looks to me like the USB connection is dropping some of the audio data, causing discontinuities in the waveform:

Tracks001.png
Is the USB turntable connected directly to the computer USB connection, or via a USB hub?
Is there a different USB socket on the computer that you could try?
Have you tried rebooting your computer?

You said you had the normal blue waves on the timeline. That’s not what I got at all.

Screen Shot 2021-08-20 at 9.58.43 AM.png
You can turn the red wave display on and off. View > Show Clipping.. All those red bars are places where the sound got so loud the digital system stopped following the music. Worse yet, the digital system starts making up its own sound and that’s the fuzzy crunch you hear.

A new Windows system may have Windows Enhancements turned on. Dig down into control panels and make sure Microphone Boost isn’t set.

Koz

Steve & Koz, thanks so much for your help. This is really highlighting how basic my Audacity skills/knowledge are as I’ve never seen those ‘views’ that you’ve posted in for me.

Steve - The USB turntable is connected directly to the computer USB connection. I have 2 traditional USB ports and 1 type C - I’ve used them all and still get the same distortion on each. (Just tried the other trad USB port again - no change I’m afraid). In terms of rebooting my computer, if you mean turn on and off again and ‘restart’ and such like then, yes, a lot. If you mean a factory default reset then, no.

Koz - Oops, yes, I see what you mean! I’ve now turned it on and re-recorded it at different levels. I can get rid of the red waves but the distortion is still there. My USB microphone doesn’t give me a ‘microphone boost’ option. It’s there on the Realtek microphone and it’s down at 0.0.

Do you still have your old computer? If you do, it would be worth testing the turntable on that to ensure that the turntable hasn’t stated playing up.

Hi Steve - yes, I’ve still got it and it works fine as it always did. The only reason I changed it is that the processor is so old and slow it ‘skips a beat’ quite often so my recordings sound like they’re jumping when they’re not.
That it works so well is one of the big mysteries for me over this new ‘improved’ laptop. It suggests the turntable, cables and so on are fine - and the Audacity settings are set exactly the same on the new laptop as they are on the old Win 7 laptop too. Aaaarggghhh!

Incidentally, here is the example of the recording with the lower levels avoiding the red waves…

and it still has the discontinuities:

Tracks002.png

That’s actually very similar to what is happening on the new machine. The difference being that instead of getting gaps, there’s just bits of the waveform missing.

Does the problem (on the new computer) happen all the way through the recording?

Hi Steve, yes, on the new laptop the distortion is present from start to end.

and on the old laptop?

Morning Steve. No, the old computer has no distortion at all, the sound is great on that one, I just get the occasional ‘jump’ or ‘skip’, on average probably 1 very brief jump every 2 songs.

What’s the make and model number of the USB turntable?

Hi Steve, it’s a Sound Lab GO56C.

I found an on-line manual, and there’s no mention of “drivers”, so I assume it uses generic Windows USB Audio drivers.

As a test, have you tried recording from your laptop’s built in microphone? (I wouldn’t expect good quality from the built-in mic, but we’re just interested in whether it has the crackly distortion).

I ran a verbal test on the laptop’s built-in microphone - which was clear as a bell - but, to be fair, as we’re trying everything else to try and fix this all-baffling issue I might as well give it a go. I’ll get on to that tomorrow and see what happens.
I have been wondering if it’s something to do with the ‘sound card’ in the laptop but as I’m a complete imbecile when it comes to IT stuff (is there even such a thing as a sound card!?!), my own musings are essentially pointless! Ha Ha, I was born too early for this stuff!

When you use a USB audio device (such as a USB turntable), it bypasses the built-in sound card. In effect, the USB audio device has its own “sound card” built-in, and that’s the one that is used when you select the USB option as the recording device in the Device Toolbar.

That makes sense, thanks Steve. I logged on tonight and saw the update to v3.0.4 which I downloaded. There was no noticeable improvement. I’ve now recorded just via the inbuilt microphone at max level 100 with the maximum available microphone boost of +10.0db. The sound is very quiet but plays back clearly - free of the distortion I’m getting via the USB input but obviously picking up any hint of background noise too.
In view of your most recent reply, I would guess that it must be something to do with the USB device/cable or my each of my USB inputs on the new laptop. But, of course, they are exactly the same items that are giving a crystal clear sound on my totally basic 10 years old + Panasonic running Windows 7 and I’m struggling to believe that all 3 USB ports would be giving the same problem!
I could try another USB cable (again) in case the new laptop just needs higher quality or something but that seems unlikely.

There’s a setting that you can change that might help:

  • “Edit menu > Preferences > Devices”
  • Try increasing the “Buffer length” a little at a time, and make a short test recording after each change.
    The default setting is 100 ms.
    Try 120, 140, 160 … up to 200.
  • Any improvement?
  • If no improvement, or if it gets worse, try going smaller: 90, 80, 70, …