MakeAudacity always use an audio channel (PulseAudio)


When Audacity is on, it does not occupy a ‘stream’ in PulseAudio, but once I start playback, it does.

Is there a way to make Audacity always occupy a stream? Sometimes I have audio delay problems and I bet forcing Audacity or PulseAudio to always have a stream reserved for Audacity might make a difference.

Video illustrating my problem:


The short answer, no, though this is something that ‘may’ happen in the future.

I can’t see your video as it is marked “private”, but I’d guess that you may be able to resolve the problem by setting Audacity to use your sound card hardware directly (rather than via pulse). To do that, select the appropriate “hw” option in the device toolbar for both Playback and Recording. Note that this probably won’t work if you are wanting to record sounds that are playing on your computer, and will probably prevent other applications from accessing the sound system while Audacity is recording or playing.

Strange. Either the video is no longer private, or your region might be blocked. I can view it without any problem.

Please, always give us the information requested in the pink panel at the top of the page.

The delay problem mentioned in the video is that audio playback in a short selection does not start immediately.

if you need to use pulse, you could try reducing “Audio to buffer” in the Audacity Recording Preferences and/or play with PULSE_LATENCY_MSEC values as per