Macros not working

I’m trying to use Macros to compress MP3 files for use in the car, using Chris’s Dynamic Compression plug-in. The plug in works perfectly when I apply it to one track at a time. When I try to apply it to, say, eight tracks of an album using a Macro that asks it to open, select all files, apply the compression then export, it appears to go through the whole process track by track, but when I open the tracks they’re still in original format. I’ve tried exporting to different folders in case it doesn’t like replacing the original file, still no success.

Which version of Audacity are you using? (look in “Audacity menu > About Audacity”).

I’m not sure what you mean by selecting all files within a macro - usually a macro operates on just one file at a time. But when you run a macro you can specify a list of files - the macro is run one time for each file in the list.

Also note that in 3.0.0 and 3.0.2 the output directory for macros was changed. Make sure you are looking in the right place for your results.

I’m running Audacity 3.0.2 on High Sierra 10.13.6.
The Macro I’ve set up calls for Select All/Compress dynamics (to particular parameters)/Export as MP3/END. I open up the files in the Macro box and activate. I watch it opening each file, applying the requested compression, then exporting exactly in the same manner as if I’d selected one track at a time instead of using the macro. Except that when I go looking for the files it has just worked on, the only ones I can find are exactly the same as before I ran the programme. Essentially, it has exported them into the ether.
I realize the options for the ‘export’ parameter in macro are limited. You can’t actually alter the parameters within the Macro box. It seems it will export only to the location you’ve last used. So anticipating there might be some issue with the export location I’ve tried different different targets - setting up a folder different from the one from which I retrieved the files, or asking it to replace the original file, or exporting to a memory stick. Nothing is working. Despite appearing to go through the requested operation, the files are unchanged.
I can pull up one track at a time without using macro, and the whole thing works tickety-boo. But with a couple of dozen albums to compress, each containing four to nine tracks, Macro in theory will save me time an constant monitoring.

Perhaps you’re looking in the wrong place for the processed files. The default location changed in Audacity 3.0.2.

:smiley: Alleluia! Audacity has created a folder ‘Macro-output’ in my Documents and there the files sit. Now, if I’d read the manual carefully … :blush:

Mind you, in my defence that info is detailed in tiny font in a green box near the foot of the page you linked. The location shown higher up the page, “/Users/(my name)/Library/Application Support/audacity/SessionData” couldn’t be found on my Mac. There’s also a reference on the page, and elsewhere in the manual, to the default location being the one used in your last session and that’s where I was going crazy looking for all the files in the locations I’d used when compressing them individually.

All’s well that ends well. Huge thanks for your help, Steve.