Macro Not Exporting Correctly

I built a macro to include Export as MP3, but when the process completes the file is nowhere to be found. I changed my default locations to Desktop on both Export and Save and still the same. Here’s my macro:

It is the “Macro Output” setting in “Preferences > Directories” that controls where exports from macros go.

I changed that to Desktop already and it’s still not exporting to the desktop.

Is it exporting to anywhere? Did the system complain? Did you get any messages? Did you try the computer search tools?

One way you can lose a file is use punctuation marks in the filename. Upper case letters, lower case letters, numbers, dash, and underscore. Those are the only safe characters in filenames. I don’t use spaces, either. Do Not use either of the slash marks in a filename.

Post back if you figure it out.

Koz

How long is the show?

Koz

Just to cover it. When you have some audio work on the timeline, can you File > Export an MP3 to the desktop? Manually, with no Macro?

You can open up a Macro in a text editor and read it.

This is a manual MP3 export panel in Audacity 3.4.2

Screen Shot 2024-05-10 at 7.07.08 PM

Is there enough information in the Macro instruction to fill in all the holes?
Koz

A Macro note. Macros are built out of English-ish words but they don’t have regular carriage returns and line breaks. So one line of instruction can fold over about a million times making it really rough to read. I reduce the font style really tiny and stretch the words across the whole screen.

Koz

Like this. Click on the image.