MacBook Pro Bug

Guys I just did a forum search and there is obviously a bug with the 2.0.5 install on the MBP. It occurs when you plug in a set of headphones (I’m using USB) and then later remove them. From that point forward Audacity seems unable to revert to using the ordinary Built In Output. Once the bug kicks in, any attempt to use Built In Output results in a popping noise then a very distant, low volume, hollow sounding playback through only one speaker (on my 2009 MBP, on the right), if at all. Sometimes there is playback and sometimes there is not.

Clearly it’s bugged. Just as clearly MBP users are going to be a key component of your Audacity-using audience. Has anyone hit on a fix for this yet? I don’t think telling people not to use a MBP is going to win you many friends. FWIW I’ve been podcasting with Audacity for going on 8 years, mostly on MBPs, and this is the first time this issue has cropped up. It has to be the new build.


Can you roll back to 2.0.3?

No-one here has MacBook Pro, which doesn’t help.

If you are on Mavericks, that new OS can mess up sound in QuickTime too.

Does playing some audio in QuickTime fix it in Audacity 2.0.5, like for others? You may have to play twice in QuickTime, as it may fail the first time.

Also if you add or remove USB devices (including headphones) while Audacity is open, note that you have to restart Audacity or use Transport > Rescan Audio Devices.


any attempt to use Built In Output results in a popping noise then a very distant, low volume, hollow sounding playback through only one speaker (on my 2009 MBP, on the right), if at all.

So the switching fails. Built-In Output and Internal Speakers are the same thing. Software senses when you plug something in the side of the Mac and is intended to switch between them.

This is the first time I heard of that particular system failing. It started happening right after you installed Audacity 2.0.5? Was it an upgrade and from what?

You’re using USB headphones. So the system isn’t really switching like it was intended. You’re switching between two totally different sound systems. Close Audacity. Do the systems work naturally? Do you hear iTunes on your USB headset? Do you know how to switch between USB and analog in iTunes? I do it in System Preferences.

If you plug and unplug a set of earbuds in the side of the Mac, do the little speakers switch like they’re supposed to – after about a second delay? Does it still sound OK when you go through all that? It’s supposed to.

Do you keep your old Audacity installers?


A few other people on MacBook Pro and Mavericks have this issue of only a pop, instead of audio, when playing in Audacity.

If the OP’s issue is the same, the problem seems to be that Audacity cannot play when it’s the first app to use the sound device. The same issue occurs if you boot the MacBook Pro and use Audacity before playing any sounds elsewhere.

On the other hand, if the headphones jack is flaky as on some MacBook Pro’s, then it’s also possible that the connectors inside the headphones port have not been properly released. Putting the phones in and out firmly may cure that.


It’s a software switch. When you plug your headphones in, nothing happens for a second while the system runs some routine or another. It’s not instant and mechanical like the side of a Windows laptop. It works that way the other direction, too. Just the fact that there is some sound coming out of the speakers means the routine succeeded – at least the switching routine succeeded. There’s still some question of why so many of them fail to deliver an actual musical show.


Hey guys -

I did a complete uninstall/reinstall and then was very careful not to unplug my headphones while listening to an Audacity track… until today. Same issue again. Luckily this time the popping noise/muted sound issue went away as soon as I plugged my headphones back in.

Right now I don’t think there’s a safe way to use the system audio on a Macbook Pro without triggering errors. While I assume those errors wouldn’t be encoded in a final MP3 output from Audacity, I haven’t been willing to put in the time on a podcast and then try it. Audacity as we all know has always been… tempermental. That’s the price you pay for free. I just wanted to let y’all know there’s a bug with OS X Mavericks/Macbook Pro and the latest build.


There is no such thing as a “complete” reinstall on Mac because there is no way to reset Audacity Preferences using the DMG installer.

Please could you help us by testing the below.

What happens if you boot the machine without the USB headphones plugged in and the built-in speakers selected in System Preferences? Is there a login sound? Can you then launch Audacity and play using the built-in audio?

What happens if you boot with USB headphones plugged in, play audio in Audacity, remove the headphones, play some audio in QuickTime, then play audio in Audacity?

It’s a playback problem, isn’t it, not a recording problem?

I understand that Koz now has a running MacBook Pro on Mavericks using Audacity 2.0.5 or 2.0.6-alpha and does not have a problem with system audio stuttering or not playing at all.

So we don’t “all know”.

Have you updated to 10.9.2 Mavericks? That has helped some users who had stutter in built-in playback.

Have you tried Audacity 2.0.3 as Koz suggested? You can get it at . Does that have the same issues?

As you may realise, free software doesn’t have full time paid developers able to spend 40 hours a week on the software. Perhaps you would like to help us by trying the things mentioned in this post?


I understand that Koz now has a running MacBook Pro on Mavericks using Audacity 2.0.5 or 2.0.6-alpha and does not have a problem with system audio stuttering or not playing at all.

To be clear, I do not have USB headphones. That is throwing mud in the game. Is this a USB Headset, by any chance, like a gaming headset with microphone? That’s even more mud. Do you have a 13" MBP? Then you also have the Headphone/Stereo Line-In bidirectional switching to deal with on top of everything else. I’m amazed it worked at all.

I’m going back and forth between earbuds/headphones and built-in speakers and that seems to work just fine. I do have 10.9.2. I did the upgrade from 10.9.1 shortly after it came out and it was a very serious upgrade. No one or two meg of data here. I had time to paint the house and buy a new car while it was downloading. They fixed many problems.

The system has to switch several different systems to go back and forth between USB routing and standard sound, so I’m not surprised if it got missed in the OS testing.

I do critical recordings, so I tend to stick one or two Audacity versions behind. I have found 2.0.3 to be very reliable and stable, so I have that installed as a “Portable” or isolated version on the 15" MBP. I have independent connections for Stereo Line-In and Headphone out.

I have Audacity 2.0.5 installed conventionally in /Applications as a normal user would install it and that’s what I’m using for testing. You might think about a similar install, particularly if it turns out 2.0.3 is unstable as well. That will be very good to know.

I do have a USB gaming headset and I can try that in the testing mix.


Guys this issue has remained a problem all year. Has anyone hit upon a fix?

We are not able to help you if you do not try the things that are suggested or let us know what happens if/when you do. We can’t see your computer.
Perhaps you could respond to some of the previous replies that have been trying to help you.