Mac sample rate error

Hello follower podcasters :wave: We are currently three episodes in on our podcast and decided to buy a microphone and need some technical expertise :slightly_smiling_face: We had a microphone originally but couldn’t get it to work so now have a different one. I have a slightly older MacBook and I have a plug in mic which all connects well. The microphone comes up on audio midi and I can’t record with the microphone on garage band and voice notes but can’t record into audacity, which is what we have used to edit so far. When I hit record in audacity, it come up with error -9997 about invalid sample rate. I seem to have tried all the sample rates possible for the mic and matched them with the audacity sample rates but frustratingly it’s still not working!! I’ve put the options of the sample rate for the microphone in a photo below and when I put those sample rates into audacity it still says the sample rate error.

We are using audacity cause it was easy but if anyone has any garage band tips cause it’s looking like we might have to swap over unless we can get this fixed.

Thank you all so much in advance for the help 🩵

(Not sure if anyone’s curious but here’s a link for our podcast [deleted]

Any advice would be greatly appreciated!!!

What kind of microphone are you using? Not the actual pickup, but where is the analog-to-digital conversion being done?

Me no speak Mac, but this forum is searchable …
https://forum.audacityteam.org/search?q=9997%20%23audacity-help-forum%3Amacos