Mac Pro Monterey-Audacity not recognising input signal from Pioneer mixer (flat line)

Mac Pro Monterey - Audacity not recognising input signal from Pioneer mixer (flat line)

Hi Team ,
Please can you help solve this issue , as i have a brand new MacBook Pro running Monterey 12, and have Audacity sound issues - no input signal .
Honestly i have tried every tech and system tip known so far !!

Audacity recently loaded is 3.2.0 for MAC latest downloaded via Application folder and not download folder as instructed ,
hardware used is USB connector between MAC connected via USB input to Pioneer DJM 900 Nexus Mixer

On Audacity - Rescanned audio devices , select device correctly as can be seen via Audio setup etc.

On MAC - All checked and changed accordingly
MAC system preferences >security & privacy > microphone enabled for Audacity and saved
MAC system preferences > sound > device selected and there is an input level bouncing sound dial of music
MAC Applications > utilities > audio mini setup > DJM - 900Nexus selected for input and output

On Audacity
all Project Rate and settings are correct
Play source and there is no input signal being detected - a flat line
The input signal can be seen on other devices therefore the Pioneer sound drivers are uploaded and correct.

Have tried reinstalling and uninstalling all applications - Audacity , Pioneer drivers etc several times

Please can you help as i have used Audacity for 5 years with no issues . But it does not work on MAC BOOK Pro using this set up – must be a setting or technical issue . Read and watched everything and really think someone at AUDACITY needs to help with this as it seems a common theme with no resolution - even if a “yes - we know it does not work” type response would save a lot of pain !

PLEASE HELP as the MAC cost me over £2k to specifically record music on

there is an input level bouncing sound dial of music

While you’re looking at the Mac System Preferences, can you overload it? Never blow into a microphone, but can you yell so loud that the display indicator goes all the way up? Sometimes purposely violating normal practices can reveal operating problems. Make the Pioneer mixer bouncing sound meter go all the way up to red. Does the pioneer and the Mac overload at about the same volume?

For one example, the Audacity default blue waves only display the loudest about 25dB of the volume range. If your show is quieter than that (easy to do with home microphones), it will seem like there’s nothing there.

For another, If you yell so loud the neighbors complain, but the system preferences never overload, then there’s something standing between your performance and the digital signal. Do you use Skype or Zoom? Those two are famous for stunts like that.

I know from personal experience that crossing Mono and Stereo by accident somewhere in the system can cause the sound channel to just flat fail instead of distorting the show, which is what I would expect.

There is that security thing, too. Newer machines need to have their “microphones” registered and vetted before they will work. About that I know zero-nothing other than it exists.

There are some exotic problems. If you personally prepared an XLR-type microphone for use and got the wiring wrong (super easy to do by accident) then the performance may work or drop dead depending on the listener. That gives you the magic problem of sending your show to five clients and two of them don’t get any show at all but the others are OK. That’s phase cancellation if you’re counting.

Let us know. Someone will know how to look up that security thing.


The forum software thinks you’re on Windows. If you’re really using a Mac, I think I can fix that listing.

One more. You mentioned having the mixer registered as both record and play back. That can hide problems. Make the playback go to the MBP speakers instead of the mixer.

There is a difference between fixing the problem and observing a change. Report if anything changes whether it fixes the problem or not.


Why are you on a new system? You still have the old system working, right? What was the old system?