Mac OS X 10.11; Audacity 2.1.1 dmg installer

I recently upgraded my Desk top Mac to OS X 10.11. I’m using mobilepre usb . I recorded a Voice track and got a repetitive click through the recording which is unusable. As a temporary work around and to see if this noise appeared in another software I recorded a voice track in Garage Band and the sound was great. I exported the the raw track to Audacity and proceed to edit - so far everything is good I have audio. I export the audacity file in 2 versions an mp3 and an aiff. Both exported files mp3 & aiff have no audio! What is going on? I would like to be able to record clean audio in Audacity edit and then export finished files in WAV mp3 or aiff - Doing this was never a problem before. Please advise. Thanks!

I recorded a Voice track

How? The Mobile Pre USB is just an interface. Not a microphone.

Both exported files mp3 & aiff have no audio!

How are you listening to them? In detail. We had a recent poster who created damaged sound files by accident which would only play on proper stereo systems. They wouldn’t play on his mono personal music player.


I use a sennheisser mic going into the xlr on my mobile pre interface. I’m listening on my headphones. I get audio with visible waveform in audacity when I export the audio to mp3 the mp3 has no visible waveform and no audio.

Is that the M-Audio Mobile Pre USB?

What model Sennheiser mic? Does it require “phantom power”? (check the user manual for the mic).
When you talk into the mic, do you see the signal light illuminate on the Mobile Pre?

Are they plugged into the Mobile Pre?
Do you hear your voice through the headphones?

Yes, M Audio MobilePre USB. Sennheiser mic is the ME66. My headphones are plugged into my desktop Mac. I don’t use the headphones when I record Never used phantom power before and everything worked. Hope this helps and thanks!

Is that with a K6 or K6-P powering module?

Everything worked when? What were you doing when it worked? What’s different? How long ago did it work?


Everything worked before I upgraded to El Capitain on my Mac

Third time asking: When you talk into the mic, do you see the signal light illuminate on the Mobile Pre?

Yes. When I talk into the mic the signal light on the MobilepreUSB is working. I just did a test recording and I am able to get clean audio on my Audacity file. I tried to export an aiff version and again no audio on the aiff file

What OS X did you upgrade from? Something old like Lion? Did you also upgrade Audacity from a previous version?

You seem to say just now you got a clean recording into Audacity, but if the clicking problem happens again, try these solutions.

Audacity > Preferences… then the “Recording” section. Set “Audio to Buffer” to zero. Record. If it stalls, set it to 10 milliseconds. Carry on increasing it by 10 millisecond increments until you get a steady recording.

Set Audacity project rate to 44100 Hz or 48000 Hz (not higher because it seems Mobile Pre’s maximum is 48000 Hz according to Then open /Applications/Utilities/Audio MIDI Setup and ensure the Mobile Pre input and output are both set to the same 44100 Hz or 48000 Hz as Audacity.

Restart Audacity.

Also note that the fewer apps and services running when recording, the better. Turning WiFi off might help. What is your information from Apple menu > About This Mac ?

Is the “no visible waveform” when you import the MP3 back into Audacity? If so, is there a flat line of the correct length, or no track at all, or just the track panel with gain/pan sliders and nothing to right of it?

How exactly do you export? What is the Audacity playback device in Device Toolbar?

I recommend you attach the log from Help > Show Log… after exporting then importing the file. Also tell us what the location of the Audacity temporary directory is (Audacity > Preferences… then the “Directories” section).


The Clicking is not a problem now. I’m getting a good level in Audacity. When I export the full or selected audio as an mp3 or aiff no sound on the exported file. If I open the exported mp3 file in Audacity. There is a wave form perfect as it should be. If I attach the mp3 -no sound from the mp3. I can attach an mp3 and send to you if that might help?

If you apparently changed nothing, the clicking “might” come back. It doesn’t happen for no reason.

Played in exactly what app? What exact location on your drive is the file playing from?

But you previously said

when I export the audio to mp3 the mp3 has no visible waveform

So in what app was or is there no visible waveform?

If you play the imported MP3 with waveform in Audacity, can you hear it? If yes, please tell us what the playback device in Device Toolbar says.

Attaching the exported MP3 might help, but only insofar as we could see its file properties. Did you add metadata to the MP3? That can faze some legacy Mac apps.


I just talked to apple and they say there is no plan to uptake audacity to work with El Capitan the new OSX system They told me that after checking audacity’s boards and advised me to use i sky soft which is.

Apple do not make Audacity, and do not contribute to Audacity’s development in any way.

Audacity does not have “boards”.

They advised you to give them money for their software. Does that surprise you?

No. But I had to give it a shot. Here’s the latest I just tried to record a test in Garageband and exported an mp3 - same thing no audio on the mp3! What do you think? I’m not giving up on you:-)

iSkysoft appears to be a media converter, and is not made by Apple.

What does iSkysoft have to do with this? Are you using iSkysoft to play the MP3’s that you export from Audacity?

Audacity basically works on El Capitan. I can say that as a member of Audacity Team who builds and tests Audacity on El Capitan.

I think if you want help, please answer as fully and clearly as you can when we ask you explicit questions. Please see

So let me ask again:

  1. In what app is there no visible waveform and no sound for the exported MP3?

  2. If you import the exported MP3 back into Audacity, assuming it has a waveform, then play it, can you hear it?

  3. If the answer to Question 2 is yes, please tell us what the playback device in Audacity’s Device Toolbar is.


Normally, I am able to click on an exported mp3 in the Finder and review the audio by tapping the spacebar on my keyboard. When I try that now there is no audio. When I open the same file in Audacity there is audio and a waveform

How do I find the playback device? Output is Core Audio?

Built in Output?

You can find the Audacity playback device by looking at the last box on the right in Device Toolbar in Audacity 2.1.1. Please click this link if you need to know more: Device Toolbar.

Then clearly it is not an Audacity problem.

Finder does not show a waveform, as far as I know. Please describe how you are playing the audio in Finder, step by step. If I export a (default for Audacity 2.1.1) 128 kbps MP3, then right-click over it in Finder and choose “Get Info”, I can click the Play button in the Preview pane in “Get Info” and hear the MP3 and watch the circular progress widget move.

I cannot press SPACE to play the file.

To select the playback device that Finder uses, open System Preferences, click “Sound” then click to select the output device and turn its volume up.