MAC OS CATALINA

I just got Catalina on my mac and have been trying to use it with audacity 2.3.2 and it will not record sound. When I check my privacy and security the audacity app doesn’t show up in the microphone tab. I followed the instructions on how to download, download the dmg for 2.3.2 then drag the audacity icon to the app folder, so I am not sure what is going on.

Audacity appears to work on Catalina for some users, but it is not yet officially supported.
This is not related to 32/64 bit applications, but rather to additional unannounced changes that Apple have made.

The fact that it seems to affect recording (for microphones and USB devices as others report) suggests that it may be down to driver issues.

WC

The issues on Catalina are NOT driver related, but related to some of the new security and permissions requirements in Catalina.

First, when an application attempts to access any sound input device, said application requires explicit permission from the user before it can access the mic. Second, there are additional protected folders in Catalina that applications also need to explicitly ask permission to access (such as Desktop and Downloads). For some reason, Audacity does not ask for these permissions, and as such can’t access the necessary resources to work.

However, there is a work around!

You can open Audacity via the terminal using the following command:
open /Applications/Audacity.app/Contents/MacOS/Audacity

This will open Audacity and then Terminal will actually ask for the correct permissions. If for some reason this doesn’t work, you can try opening Audacity as root:
sudo open /Applications/Audacity.app/Contents/MacOS/Audacity

Finally, this assume that Audacity is stored in your Applications folder. If it’s somewhere else, you’ll need to change the path in the above command:
open /location of audacity/Audacity.app/Contents/MacOS/Audacity

For example:
open /Applications/Utilities/Audacity.app/Contents/MacOS/Audacity

Hopefully these issues can be solved in short order (I haven’t run into anything similar with other apps).

Have you tried making a Desktop alias to the Audacity executable? If so, does that work for you?

I tried launching Audacity from desktop alias and it does work !

Awesome, that works!

Very useful insight there noraa :ugeek: :sunglasses:

Once I’d found out where Apple hide the Terminal app :wink:

On first use it asked told me that audacity wanted to access the mic - and did I want to allow it (just as in 1.14 Mojave)

But on second on subsequent launches by this method it just launches.

Also, if I leave it active (black dot) in the bottom dock I can just relaunch from the Audacity logo.


So how did you make that trick work noraa :question:

Thanks for these valuable insights, much appreciated.

Peter.

See this Forum announcement Audacity under macOS 10.15 Catalina

And many thanks to noraa for posting that workaround

Peter

Hey Peter,

I’m so glad my post was able to help people! That’s awesome, as I literally joined these forums just to post that.

In any case, I noticed in your announcement that there’s a typo in “Step 2.” It should state “2.) Open Terminal.app” not “2.) Open Finder.app”

I’m wondering if that may be throwing some forum users for a bit of a loop.

So making a desktop alias of the Audacity executable requires you to open up the contents of the Audacity.app package. To do so:

• Right click (or two finger click, depending on how you have your mouse/trackpad setup) on Audacity.app (which, in the Finder, is essentially the app itself).
• In the right-click menu, select “Show Package Contents.” This will open a new window with the contents of the Audacity.app package, and it looks just like any other folder.
• in the package contents folder, navigate to the “Contents” folder, and then the “MacOS” folder.• In the MacOS folder, there is an item simply labeled “Audacity” with NO file extension. This is the Audacity Unix executable.
• Drag this file to the desktop while holding down the “Control” key. This will make a shortcut of the executable that can be simply double clicked on.
• When the exe is opened, Terminal will open first, and the Audacity will open.

There is one big caveat to using the above method: In order to open up an Audacity project, it must be opened from within Audacity AFTER you open Audacity following the above methods. If you just double click on an Audacity project, it will open Audacity as normal, and things just won’t work properly.

Not sure if this is allowed in the forums or not, but I created a really simply “Automator” script that you can simply double-click on to open Audacity and have it working. Because Automator allows you to save these scripts as an application, you can actually pin the script to the Dock just like any other program.

I’d be more than happy to throw it up on a file sharing site and post the link here, but like I said, not sure if sharing files like that is allowed here or not.

Good catch I’ve fixed that

And I fixed on our Website too:
https://www.audacityteam.org/macos-10-15-catalina-is-not-yet-supported-by-audacity/

Many thanks,
Peter

The workaround doesn’t seem to work on my MacBook. What do I do?

In what way does it “not work”?

It keeps saying “Bad CPU type”.

Where did you get Audacity from?
If you downloaded it, approximately when did you download it?

I downloaded Audacity about a year ago when I first got my MacBook. Now, whenever I try to open Audacity, it refuses to do so.

You need to use the latest version of Audacity. You can get it via the Audacity website: Audacity ® | Download for Mac OS

Downloading the latest version worked! A thousand thanks for your help!