Mac Finder: double click or "Open With" broken

In past versions of Audacity (Mac) (with Audacity set as the default program for file types), double-clicking such a file in a finder window - or right-clicking a file to bring the dropdown “open with” - would call Audacity to open the file.

This behavior seems broken in 2.2.2.
I can see Audacity blink, but the file doesn’t open. The only way to open a file now is from within Audacity…>File>Open.

MacOS 10.13.3 High Sierra

What’s the filename your graphic covers up?

I did notice that my system will occasionally “forget” the filename associations. That’s scary, but not fatal so far.

Right-Click or Control-Click the file > Get INFO > Open With (and then) Use this application to open all files like this.


The file under the dialog is a .wav.
I set all the associations in the finder Get Info window as you describe when I first started using Audacity, and reset them with the new version of Audacity.
I set them for .wav, .aiff, .mp3, .m4a - which is all the types I run into in the course of business.

I’ll try deleting the older version of Audacity and see if that makes a difference and come back with results.

jonburr: I can reproduce your issue on MacOS 10.13.3, Audacity 2.2.2. Are you trying to open projects created before Audacity v2.2.0 or older versions?

I cannot double click to open my colleague’s projects (I think he is using some older version). But I can open multiple projects created by v2.2.2 at the same time. Can you give it a try? Just create two new projects and check if you can double click to open them.

Project (.aup) files work fine (I just started using those, never had saved em before)

After deleting an older version of Audacity, double-clicked .wav files are opening Audacity when it’s set as the default -
but still not mp3 or m4a. (Didn’t test aiff yet).