M-Audio fast track ultra 8R - 8 channel option [SOLVED]

Hi Guys

My first post so if i have missed anything please let me know…

i have tried to resolve the issue myself but have had no luck, I have searched through forums and online material but cannot find the help i need…

system details -

windows 7 professional
service pack 1
64 bit o/s

running audacity 2.1.1

audio interface - m audio fast track ultra 8r usb

i have been recording my drum kit for around 4-5 weeks using the m audio interface without any issues, recordings been fine and preferences had been set where required etc etc etc so all good.
When recording i would multitrack record using all 8 channels and then delete 3 tracks as i only have 5 mics…fine no problems for the first 4/5 weeks…

about a week ago i went to record as i would do, and encountered an issue with the drop down menu not showing my 8 channels option… i have made no changes to anything in regards to the process i follow or computer changes etc etc it was there one day and not the next…

my typical setting that i have been using with no problems were -

windows wasapi multichannel (m-audio fast track 8R) 8 channel

now for some reason all i’m getting in the drop down menu is
1 (mono) record
2 (stereo) record

no channel 8 option???

i have been through all my options in the devices & printers sections, checked device properties, audacity preferences (all options tried to see if i could get one option to show 8 channels),also i’ve checked drivers, reinstalled drivers, checked for updates uninstalled interface restored etc etc

I haven’t seen the 8 channel option while changing and exploring different options etc.

Can anyone please help…!!!

again as mentioned at the start if i have missed anything please could you let me know

cheers guys


That is a very complete spec list. Thanks for that!

The first thing that springs to my mind with M-audio interfaces is: Is your driver up-to-date?


The most recent update seems to be from Dec 16, 2014.


I have installed and restored the latest driver twice still nothing,

I believe th latest driver is 6.1.9 July 11 2013…

All channels light up on interface as normal, so can only assume it’s some kind of software issue
Very frustrating


I bet you’re wondering what could happen to the machine in the face of you doing nothing at all between the two times.

So are we.

Do you have Windows set for Auto Update? There’s a chance that the machine you left and the machine you have now are not the same machine. I don’t let anything auto update. I make systems tell me when they want to make changes and I’ll tell them when it’s OK to do them.

There’s just nothing like being hired to do a good job and arrive with a machine not able to perform “for some reason.”


Open “Help > Audio Device Info”, then copy and paste the info into your reply. That may give us some clue as to what is going on.

That is fine on Windows 7 which asimo2015 has, but it is much harder advice to follow on Windows 10 :wink:.

And even on Mac you have to dig into settings to stop everything updating automatically.


**** ISSUE FIXED *****

Hi Guys,

i have managed to fix this error eventually, hopefully and fingers crossed i have rectified this error if however i come to record and my 8 channel option isn’t available then i may be back- as i previously mentioned it was there one day and gone the next :wink:

anyway details below of problem encountered and my fix for anyone who may find this issue when trying to record
i have tried and tested and all seems back up and running for the time being…

Initial Problem detail -

using the m - audio fast track 8r interface usb

8 channel option in drop down menu not showing, only options available are

1 (mono) record
2 (stereo) record


note: details in section 1 & 2 are for reference just in case you missed something etc section 3 was my actual fix

  1. ensure all the settings are correct in the following areas
    devices and printers - devices - fast track ultra 8R - Right click - sound settings and properties

  2. in audacity go to edit - prefernces - devices -
    interface host set to : windows wasapi playback: speakers / headphones ( or your choice etc etc )
    Recordining: device multichannel (M-AUDIO FAST TRACK ULTRA 8R) CHANNELS 8

  3. everything started working again after i had updated windows with the following updates, initally these were in my update screen as optional updates which i did not previously update and install as i assumed if they were important or software dependant updates i assume i would be notified some how i guees… any way windows up dates are as followed

update for Microsoft windows (kb3080149)
update for Microsoft windows (kb3078667)
update for Microsoft windows (kb3077715)
update for Microsoft windows (kb3075249)

i know some of these options are for Microsoft to collect certain technical data for improvements etc etc if unsure just read online before you install, i’m just detailing how i corrected my issue i had with audacity and you install these updates at your own discretion.

once installed just restart computer plug USB in before you open audacity then bingo hopefully it will work,how and why these updates corrected the issue i do not know but they have sorted it… touch wood everything will be ok.

thanks for all your replies and advice

much appreciated…!!!

Thanks for the update.
I’ve marked this issue as “solved”.