M Audio Fast Track Pro

I’m unable to record via my M Audio Fast Track Pro usb with Audacity 2.1.3 on Windows 10 and am having trouble locating any relevant tutorial as to what I may be missing. Would appreciate some help. Thanks.

Connect the USB device to the computer before you launch Audacity.
Check in the Windows Sound Control Panel that the device is enabled and active.
Launch Audacity and select the USB device in the device toolbar.

Many thanks. Followed your advice to the letter. Everything appears to be enabled correctly not only in the Windows Sound Control Panel but what’s indicated in the Sys Tray as well. No problem hearing the right and left audio test with head phones plugged directly into the M Audio hardware but it’s still not recording in Audacity 2.1.3. I have a dual boot capability on this machine, so tomorrow I’ll install the Linux Mint 18 Cinnamon 64 bit ISO file I downloaded tonight and see if that works or not in the Linux O.S. If you have another suggestion or two please feel free to weigh in. Muchly appreciated!

So what’s it doing when you try to record? Does it record a flat line? Does it record a waveform but the waveform does not plat back? Does it give an error? Does your computer crash? Does it create a new audio track and then freeze? Does it do nothing at all? Something else?

Records a flat line. Nothing else. I’m now going to see if this occurs on my other production room computer. If it’s now happening on both machines that would be useful info. If it’s just this one machine I’ll probably do a complete restore from a month ago.

Check that it really is recording silence and not just “very quiet”. To do that, try to apply the Amplify effect. If it really is “flat line” (absolute silence), the Amplify effect will say that the “New Peak Amplitude” is “-infinity”.

Are you recording a mono track or a stereo track?

All my sound for my broadcast website archive is recorded in mono although I experimented with the stereo option to see if there might be something on one of the two channels and there wasn’t.

You’re not giving much information, which makes it difficult to help you.
What are you trying to record?
Have you tried amplifying the recording? If so, what happened?
What do you have selected in the device toolbar?
Do you see the meters jumping up and down in the Windows Sound Control Panel when you input a signal to the Fast Track Pro?