LV2 plugins do no work (all)

I’ve a problem with all LV2 plugins in Audacity version 2.3.3 (also with 2.3.2 installed via ubuntu repository).
Before posting here I’ve Google searched a lot to find a possible solution. I’ve searched this forum too.
I’ve installed various LV2 plugins from ubuntu repository (e.g. abgate, dpf-plugins-lv2, lsp-plugins-lv2, …). Obviously the audacity LV2 support is enabled.
Once i try to enable any plugin (via Plugin Manager) i get:

Effect or Command at (> url> )
(> plugin name> ) failed to register:
Could not load the library

Can you suggest a solution?

Thanks in advance for your support :wink:

Kind regards,

Description: Ubuntu 19.10
Release: 19.10
Codename: eoan
Audacity v2.3.3 installed via ppa:ubuntuhandbook1/audacity
(previously I had Audacity v2.3.2 from repository)

I’ve just tested on Ubuntu 19.10, Audacity 2.3.3, MDA LV2 (all default repository versions). I can enable these LV2 plug-ins.

Not all LV2 plug-ins will work. In particular, LV2 synths are unlikely to work.
There have been improvements made to LV2 support for the next version of Audacity, so more LV2 plug-ins will work.

Thank you so much Steve. I’ll wait for the next version of Audacity :wink:

Did you try the MDA LV2 plug-ins?

Hi Steve,
I’ve Installed the mda-lv2 v. 1.2.2~dfsg0-2. Some of the various plugin work.
But I need more (and several) effects e.g a good parametric EQ (to remove spatial echo from voices).
No LSP (Linux Studio Plugins) works, neither LDASPA nor LV2.
I tried the VST version of the LSP: I can enable them, show them but not apply the effect (only via macro workaround).
Figure/Attachment: Parametric EQ (VST version), Apply button does nothing.
VST support is another big problem… but it’s off topic :slight_smile:

Thanks again for your support.
Kinds Regards,


I can’t see in that screenshot - do you have some audio selected?

Yes, the audio is selected. The effect works but when you click on Apply (“Applica” in my system) there is no response.
So I need to create a macro with that effect and then apply the macro to the selected audio… :neutral_face:
It’s hard work :smiley: