LP Recording...never more

I recently installed Audacity after buying a Music Hall USB turntable… everything feel into place, I began copying my ol’ LP collection to my computer. After 6 albums, recording ceased for no readily apparent reason. I have checked all physical connections (no issues) and reloaded Audacity in desperation (n o help). I can import an existing file into Audacity and play it, my turntable is work as expected… the only event I can relate to this problem is a “dispute” between iTunes and Windows Media as to who should be the default (iTunes)…I made no intentional changes to Audacity preferences. I’m sure this is a matter of some no so clever oversight on my part but I need a clue!

What is the Audacity version number?


iTunes and Windows Media Player shouldn’t affect recording.

Does the USB turntable still show-up as the selected [u]Recording Device[/u]?

If you have a desktop or tower computer with a regular soundcard and line-inputs, you can try the turntable’s analog line outputs.

Version: Audacity 2.1.0

The turntable shows up as a device in Windows “USB Audio CODEC” and Audacity “Line (4-USB Audio CODEC”

Try rebooting the computer. USB recording devices do not work for weeks on end without reboot.

The current Audacity version is 2.1.2 http://audacityteam.org/download/windows


I have rebooted many times… no change. The USB device comes and goes when I plug and unplug, the turntable is producing an audio signal. Is there a way to check whether or not the computer is seeing the turntable audio signal without using Audacity?

If you can see the turntable in Windows Sound then the computer can see it.

What exactly are the symptoms of the problem? If the blue Pause button goes down when you record, turn off Transport > Sound Activated Recording in the Audacity menus.

Often, problems with USB turntables and cassette decks can be solved by changing the USB cable.


Changed the USB cable… no change… “USB Audio Device” is seen by my computer Devices and Printers), the analog turntable output drives my speakers just fine, I successfully recorded six LPs before the mysterious stop…my audio dealer will call Music Hall tomorrow…and I have repeated the uninstall/install steps once again.

Then as Doug said, if you have a tower computer with a blue line-in port, you could connect the analogue turntable output to the computer and record from line-in.

Or it “might” work if you have a mic input but it is one of the low quality “compatible” stereo inputs that some computers have.


Thanks, tried the computer “line In” and “Phono Output”… no joy

At this point I’m thinking the turntable may have gone bad…

Is there a line-phono or line-preamp switch on the turntable? (If so, set it to 'line" when using the analog line-input on your soundcard.) If there’s a volume/gain control on the turntable, make sure it’s turned up.

What do you have that you can swap-around? Do you have a stereo system or a TV audio inputs/outputs? Or a CD or DVD player with RCA left & right outputs?

For example, you can check the turntable’s analog outputs by plugging it into your stereo or TV.

Or, you can plug your CD/DVD player, or TV, or your smart phone into your soundcard to see if you can record it.

Using the RCA output of the TT and the PC Line In produces the same result…flat line. Recording value defaults to 0 over and over…don’t know what the means, moving it higher does not change anything.
Audacity Screen3.JPG
Audacity Screen2.JPG

“Line (5 - USB AUDIO CODEC)” which you have selected as recording device in Device Toolbar is not a built-in computer input.

Unless you have a blue computer line-in separate from the mic input, there is no guarantee you will get a good recording that way.


I do have a Line In and a Mic Input on my PC. Uninstalled and installed 2.1.2… no change. I added several screen shots…

And more shots…my choices

You said you wanted to try the Line-in on your PC.

The Line-in on your PC is the blue port in your screenshot. According to your screenshot you have no cable connected to the blue port.

If you want to use that blue port, you must use an RCA stereo male to 1/8 inch TRS stereo male adaptor cable. Connect the red and white end of the cable to the RCA outs of the turntable. Connect the TRS end of the cable to the blue Line-in port.

Then on the Recording tab of Windows Sound, you should see that “Line In (2 - Realtek High Definition Audio)” is connected. If you see that it is disabled, right-click over it and choose “Enable”. Also right-click over it and choose “Set as Default Device” if it is not already default.

Then restart Audacity and choose “Line In (2 - Realtek High Definition Audio”) as the Audacity recording device.

If you want to use whatever Line In is the “5 - USB Audio CODEC” then you will need to connect an appropriate cable from RCA outputs of the turntable to Line In of that USB audio device. What device exactly is that “5- USB Audio CODEC”? Tell us its make and model number.


Not sure what a TRS cable is but I do have a cable that can go from the Phono Out to Line In (blue)…I have done that with no signal result. During a lull in the action I pulled my PC apart and dusted the inside after disconnecting everything (cleanliness is reputably next to Godliness). I then carefully re-connected everything…connecting the TT USB cable toone of the PC’s USB ports…and I got a signal! I then connected my Amp and lost the signal! More connecting changing brought back the signal, yet more futzing lost the signal. I’m without a signal at the moment, don’t know if this is an Audacity problem or a W7 problem.

A TRS cable is suitable for connecting to the line-in (blue). See https://en.wikipedia.org/wiki/Phone_connector_(audio)#Modern_connectors.

This is the sort of cable you need for that Audio AUX 3 5mm 1 8" TO RCA Male TO Male Stereo Cable.

If you are now using the USB connection of the turntable to a USB port on the computer, make sure that USB port is empty (don’t use a USB computer hub). Try different USB cables.


In your first screenshot you’ve selected “Line (6-USB CODEC)”. I ASSUME that the USB turntable. It’s NOT your soundcard’s line-input because your internal soundcard is not USB.

In your 2nd screenshot you’ve selected 'Digital Audio (S/PDIF)", which has nothing to do with your turntable (unless there’s something you didn’t tell us).

connecting the TT USB cable to one of the PC’s USB ports…and I got a signal! I then connected my Amp and lost the signal! More connecting changing brought back the signal,

Did you lose the analog signal to the amp too?